gnu: fcgi: Update to 2.4.2.
* gnu/packages/web.scm (fcgi): Update to 2.4.2. [source]: Use GIT-FETCH and GIT-FILE-NAME. Remove obsolete patches. [native-inputs]: Add autoconf, automake, and libtool. * gnu/packages/patches/fcgi-2.4.0-gcc44-fixes.patch, gnu/packages/patches/fcgi-2.4.0-poll.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.master
parent
9530c4bfc9
commit
c7164ad65f
|
@ -825,8 +825,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/fasthenry-spSolve.patch \
|
%D%/packages/patches/fasthenry-spSolve.patch \
|
||||||
%D%/packages/patches/fasthenry-spFactor.patch \
|
%D%/packages/patches/fasthenry-spFactor.patch \
|
||||||
%D%/packages/patches/fbreader-curl-7.62.patch \
|
%D%/packages/patches/fbreader-curl-7.62.patch \
|
||||||
%D%/packages/patches/fcgi-2.4.0-gcc44-fixes.patch \
|
|
||||||
%D%/packages/patches/fcgi-2.4.0-poll.patch \
|
|
||||||
%D%/packages/patches/feh-fix-tests-for-imlib2-1.6.patch \
|
%D%/packages/patches/feh-fix-tests-for-imlib2-1.6.patch \
|
||||||
%D%/packages/patches/fifo-map-fix-flags-for-gcc.patch \
|
%D%/packages/patches/fifo-map-fix-flags-for-gcc.patch \
|
||||||
%D%/packages/patches/fifo-map-remove-catch.hpp.patch \
|
%D%/packages/patches/fifo-map-remove-catch.hpp.patch \
|
||||||
|
|
|
@ -1,14 +0,0 @@
|
||||||
Taken from http://pkgs.fedoraproject.org/cgit/rpms/fcgi.git/plain/fcgi-2.4.0-gcc44_fixes.patch.
|
|
||||||
Fixes compilation with GCC 4.4 and later.
|
|
||||||
|
|
||||||
diff -up fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes fcgi-2.4.0/libfcgi/fcgio.cpp
|
|
||||||
--- fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes 2002-02-24 21:12:22.000000000 +0100
|
|
||||||
+++ fcgi-2.4.0/libfcgi/fcgio.cpp 2009-02-15 11:35:18.000000000 +0100
|
|
||||||
@@ -23,6 +23,7 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#include <limits.h>
|
|
||||||
+#include <cstdio>
|
|
||||||
#include "fcgio.h"
|
|
||||||
|
|
||||||
using std::streambuf;
|
|
|
@ -1,89 +0,0 @@
|
||||||
Taken from http://pkgs.fedoraproject.org/cgit/rpms/fcgi.git/plain/fcgi-2.4.0-poll.patch
|
|
||||||
Fixes CVE-2012-6687.
|
|
||||||
|
|
||||||
Author: Anton Kortunov <toshic.toshic@gmail.com>
|
|
||||||
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/libfcgi/+bug/933417
|
|
||||||
Description: use poll in os_unix.c instead of select to avoid problem with > 1024 connections
|
|
||||||
Forwarded: yes, fastcgi-developers@mailman.fastcgi.com
|
|
||||||
|
|
||||||
diff --git a/libfcgi/os_unix.c b/libfcgi/os_unix.c
|
|
||||||
index 73e6a7f..af35aee 100755
|
|
||||||
--- a/libfcgi/os_unix.c
|
|
||||||
+++ b/libfcgi/os_unix.c
|
|
||||||
@@ -42,6 +42,7 @@ static const char rcsid[] = "$Id: os_unix.c,v 1.37 2002/03/05 19:14:49 robs Exp
|
|
||||||
#include <sys/time.h>
|
|
||||||
#include <sys/un.h>
|
|
||||||
#include <signal.h>
|
|
||||||
+#include <poll.h>
|
|
||||||
|
|
||||||
#ifdef HAVE_NETDB_H
|
|
||||||
#include <netdb.h>
|
|
||||||
@@ -103,6 +104,9 @@ static int volatile maxFd = -1;
|
|
||||||
static int shutdownPending = FALSE;
|
|
||||||
static int shutdownNow = FALSE;
|
|
||||||
|
|
||||||
+static int libfcgiOsClosePollTimeout = 2000;
|
|
||||||
+static int libfcgiIsAfUnixKeeperPollTimeout = 2000;
|
|
||||||
+
|
|
||||||
void OS_ShutdownPending()
|
|
||||||
{
|
|
||||||
shutdownPending = TRUE;
|
|
||||||
@@ -168,6 +172,16 @@ int OS_LibInit(int stdioFds[3])
|
|
||||||
if(libInitialized)
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
+ char *libfcgiOsClosePollTimeoutStr = getenv( "LIBFCGI_OS_CLOSE_POLL_TIMEOUT" );
|
|
||||||
+ if(libfcgiOsClosePollTimeoutStr) {
|
|
||||||
+ libfcgiOsClosePollTimeout = atoi(libfcgiOsClosePollTimeoutStr);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ char *libfcgiIsAfUnixKeeperPollTimeoutStr = getenv( "LIBFCGI_IS_AF_UNIX_KEEPER_POLL_TIMEOUT" );
|
|
||||||
+ if(libfcgiIsAfUnixKeeperPollTimeoutStr) {
|
|
||||||
+ libfcgiIsAfUnixKeeperPollTimeout = atoi(libfcgiIsAfUnixKeeperPollTimeoutStr);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
asyncIoTable = (AioInfo *)malloc(asyncIoTableSize * sizeof(AioInfo));
|
|
||||||
if(asyncIoTable == NULL) {
|
|
||||||
errno = ENOMEM;
|
|
||||||
@@ -755,19 +769,16 @@ int OS_Close(int fd)
|
|
||||||
|
|
||||||
if (shutdown(fd, 1) == 0)
|
|
||||||
{
|
|
||||||
- struct timeval tv;
|
|
||||||
- fd_set rfds;
|
|
||||||
+ struct pollfd pfd;
|
|
||||||
int rv;
|
|
||||||
char trash[1024];
|
|
||||||
|
|
||||||
- FD_ZERO(&rfds);
|
|
||||||
+ pfd.fd = fd;
|
|
||||||
+ pfd.events = POLLIN;
|
|
||||||
|
|
||||||
do
|
|
||||||
{
|
|
||||||
- FD_SET(fd, &rfds);
|
|
||||||
- tv.tv_sec = 2;
|
|
||||||
- tv.tv_usec = 0;
|
|
||||||
- rv = select(fd + 1, &rfds, NULL, NULL, &tv);
|
|
||||||
+ rv = poll(&pfd, 1, libfcgiOsClosePollTimeout);
|
|
||||||
}
|
|
||||||
while (rv > 0 && read(fd, trash, sizeof(trash)) > 0);
|
|
||||||
}
|
|
||||||
@@ -1116,13 +1127,11 @@ static int is_reasonable_accept_errno (const int error)
|
|
||||||
*/
|
|
||||||
static int is_af_unix_keeper(const int fd)
|
|
||||||
{
|
|
||||||
- struct timeval tval = { READABLE_UNIX_FD_DROP_DEAD_TIMEVAL };
|
|
||||||
- fd_set read_fds;
|
|
||||||
-
|
|
||||||
- FD_ZERO(&read_fds);
|
|
||||||
- FD_SET(fd, &read_fds);
|
|
||||||
+ struct pollfd pfd;
|
|
||||||
+ pfd.fd = fd;
|
|
||||||
+ pfd.events = POLLIN;
|
|
||||||
|
|
||||||
- return select(fd + 1, &read_fds, NULL, NULL, &tval) >= 0 && FD_ISSET(fd, &read_fds);
|
|
||||||
+ return poll(&pfd, 1, libfcgiIsAfUnixKeeperPollTimeout) >= 0 && (pfd.revents & POLLIN);
|
|
||||||
}
|
|
||||||
|
|
||||||
/*
|
|
|
@ -546,21 +546,24 @@ supported at your website.")
|
||||||
(define-public fcgi
|
(define-public fcgi
|
||||||
(package
|
(package
|
||||||
(name "fcgi")
|
(name "fcgi")
|
||||||
(version "2.4.0")
|
(version "2.4.2")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method git-fetch)
|
||||||
;; Upstream has disappeared.
|
;; Upstream has disappeared.
|
||||||
(uri (string-append "https://sources.archlinux.org/other/packages/fcgi/"
|
(uri (git-reference
|
||||||
"fcgi-" version ".tar.gz"))
|
(url "https://github.com/FastCGI-Archives/fcgi2")
|
||||||
|
(commit version)))
|
||||||
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32 "1jhz6jfwv5kawa8kajvg18nfwc1b30f38zc0lggszd1vcmrwqkz1"))))
|
||||||
"1f857wnl1d6jfrgfgfpz3zdaj8fch3vr13mnpcpvy8bang34bz36"))
|
|
||||||
(patches (search-patches "fcgi-2.4.0-poll.patch"
|
|
||||||
"fcgi-2.4.0-gcc44-fixes.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
;; Parallel building is not supported.
|
;; Parallel building is not supported.
|
||||||
(arguments `(#:parallel-build? #f))
|
(arguments `(#:parallel-build? #f))
|
||||||
|
(native-inputs
|
||||||
|
`(("autoconf" ,autoconf)
|
||||||
|
("automake" ,automake)
|
||||||
|
("libtool" ,libtool)))
|
||||||
;; This is an archived fork of the original home page, www.fastcgi.com.
|
;; This is an archived fork of the original home page, www.fastcgi.com.
|
||||||
(home-page "https://fastcgi-archives.github.io/")
|
(home-page "https://fastcgi-archives.github.io/")
|
||||||
(synopsis "Language-independent, high-performant extension to CGI")
|
(synopsis "Language-independent, high-performant extension to CGI")
|
||||||
|
|
Reference in New Issue