gnu: gobject-introspection: Update to 1.44.0.
* gnu/packages/glib.scm (gobject-introspection): Update to 1.44.0. [source]: Use mirror://gnome. [arguments]<#:phases>: Remove. * gnu/packages/patches/gobject-introspection-cc.patch: Rewrite to set os.environ['CC'] in 'giscanner/__init__.py'.master
parent
b837e658bd
commit
cc84b08c78
|
@ -207,14 +207,14 @@ dynamic loading, and an object system.")
|
||||||
(define gobject-introspection
|
(define gobject-introspection
|
||||||
(package
|
(package
|
||||||
(name "gobject-introspection")
|
(name "gobject-introspection")
|
||||||
(version "1.42.0")
|
(version "1.44.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "http://ftp.gnome.org/pub/GNOME/sources/"
|
(uri (string-append "mirror://gnome/sources/"
|
||||||
"gobject-introspection/" (version-major+minor version)
|
"gobject-introspection/" (version-major+minor version)
|
||||||
"/gobject-introspection-" version ".tar.xz"))
|
"/gobject-introspection-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1xwm7wmr9r9wp6xljb3bckx3a4siybavaq39w46ly7gpskxfv8iv"))
|
(base32 "1b972qg2yb51sdavfvb6kc19akwc15c1bwnbg81vadxamql2q33g"))
|
||||||
(patches (list
|
(patches (list
|
||||||
(search-patch "gobject-introspection-cc.patch")
|
(search-patch "gobject-introspection-cc.patch")
|
||||||
(search-patch
|
(search-patch
|
||||||
|
@ -243,14 +243,7 @@ dynamic loading, and an object system.")
|
||||||
(arguments
|
(arguments
|
||||||
`(;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
|
`(;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
|
||||||
;; some tests to fail.
|
;; some tests to fail.
|
||||||
#:tests? #f
|
#:tests? #f))
|
||||||
#:phases
|
|
||||||
(alist-cons-before
|
|
||||||
'configure 'patch-paths
|
|
||||||
(lambda _
|
|
||||||
(substitute* "giscanner/sourcescanner.py"
|
|
||||||
(("GUIX_GCC_PATH") (which "gcc"))))
|
|
||||||
%standard-phases)))
|
|
||||||
(home-page "https://wiki.gnome.org/GObjectIntrospection")
|
(home-page "https://wiki.gnome.org/GObjectIntrospection")
|
||||||
(synopsis "Generate interface introspection data for GObject libraries")
|
(synopsis "Generate interface introspection data for GObject libraries")
|
||||||
(description
|
(description
|
||||||
|
|
|
@ -1,14 +1,11 @@
|
||||||
--- a/giscanner/sourcescanner.py 2013-12-15 23:03:54.002937000 +0100
|
Use gcc as the default C compiler if CC is not set.
|
||||||
+++ b/giscanner/sourcescanner.py 2013-12-15 23:04:50.322937000 +0100
|
|
||||||
@@ -277,6 +277,11 @@
|
|
||||||
defines = ['__GI_SCANNER__']
|
--- gobject-introspection-1.44.0.orig/giscanner/__init__.py 2014-08-04 22:37:07.000000000 +0800
|
||||||
undefs = []
|
+++ gobject-introspection-1.44.0/giscanner/__init__.py 2015-04-20 17:30:26.507697234 +0800
|
||||||
cpp_args = os.environ.get('CC', 'cc').split() # support CC="ccache gcc"
|
@@ -22,3 +22,5 @@
|
||||||
+ if (cpp_args == ['cc'] and
|
builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
|
||||||
+ not any(map(lambda x: os.access(os.path.join(x, 'cc'), os.X_OK),
|
if builddir is not None:
|
||||||
+ os.environ.get('PATH').split(':')))):
|
__path__.append(os.path.join(builddir, 'giscanner'))
|
||||||
+ cpp_args = ['GUIX_GCC_PATH']
|
+if not 'CC' in os.environ:
|
||||||
+
|
+ os.environ['CC'] = 'gcc'
|
||||||
if 'cl' in cpp_args:
|
|
||||||
# The Microsoft compiler/preprocessor (cl) does not accept
|
|
||||||
# source input from stdin (the '-' flag), so we need
|
|
||||||
|
|
Reference in New Issue