gnu: Remove libtommath-1.1.
* gnu/packages/multiprecision.scm (libtommath-1.1): Delete variable. * gnu/packages/patches/libtommath-fix-linkage.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I3a2bb697cbb72716756c24643920008e919889b5master
parent
3da49b1472
commit
cd042f3a8e
|
@ -1608,7 +1608,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libtiff-CVE-2022-34526.patch \
|
%D%/packages/patches/libtiff-CVE-2022-34526.patch \
|
||||||
%D%/packages/patches/libtirpc-CVE-2021-46828.patch \
|
%D%/packages/patches/libtirpc-CVE-2021-46828.patch \
|
||||||
%D%/packages/patches/libtirpc-hurd.patch \
|
%D%/packages/patches/libtirpc-hurd.patch \
|
||||||
%D%/packages/patches/libtommath-fix-linkage.patch \
|
|
||||||
%D%/packages/patches/libtommath-integer-overflow.patch \
|
%D%/packages/patches/libtommath-integer-overflow.patch \
|
||||||
%D%/packages/patches/libtool-grep-compat.patch \
|
%D%/packages/patches/libtool-grep-compat.patch \
|
||||||
%D%/packages/patches/libtool-skip-tests2.patch \
|
%D%/packages/patches/libtool-skip-tests2.patch \
|
||||||
|
|
|
@ -505,28 +505,3 @@ integer library written entirely in C. It's designed to provide an API that is
|
||||||
simple to work with that provides fairly efficient routines that build out of
|
simple to work with that provides fairly efficient routines that build out of
|
||||||
the box without configuration.")
|
the box without configuration.")
|
||||||
(license unlicense)))
|
(license unlicense)))
|
||||||
|
|
||||||
(define-public libtommath-1.1
|
|
||||||
(package
|
|
||||||
(inherit libtommath)
|
|
||||||
(version "1.1.0")
|
|
||||||
(source
|
|
||||||
(origin
|
|
||||||
(method url-fetch)
|
|
||||||
(uri (string-append "https://github.com/libtom/libtommath/releases/"
|
|
||||||
"download/v" version "/ltm-" version ".tar.xz"))
|
|
||||||
(sha256
|
|
||||||
(base32
|
|
||||||
"1bbyagqzfdbg37k1n08nsqzdf44z8zsnjjinqbsyj7rxg246qilh"))
|
|
||||||
(patches (search-patches "libtommath-fix-linkage.patch"))))
|
|
||||||
(arguments
|
|
||||||
(substitute-keyword-arguments (package-arguments libtommath)
|
|
||||||
((#:phases phases)
|
|
||||||
`(modify-phases ,phases
|
|
||||||
(add-after 'unpack 'patch-coreutils-call
|
|
||||||
(lambda _
|
|
||||||
;; Don't pull in coreutils.
|
|
||||||
(substitute* "makefile_include.mk"
|
|
||||||
(("arch") "uname -m"))
|
|
||||||
#t))))
|
|
||||||
((#:test-target _) "test_standalone")))))
|
|
||||||
|
|
|
@ -1,55 +0,0 @@
|
||||||
https://github.com/libtom/libtommath/commit/93dea3a4162527346cd8856bfda6f17ffe98ab04.patch
|
|
||||||
|
|
||||||
From 93dea3a4162527346cd8856bfda6f17ffe98ab04 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Steffen Jaeckel <s@jaeckel.eu>
|
|
||||||
Date: Thu, 31 Jan 2019 14:12:03 +0100
|
|
||||||
Subject: [PATCH] makefile.shared: fix compilation and linkage
|
|
||||||
|
|
||||||
---
|
|
||||||
makefile.shared | 15 ++++++++-------
|
|
||||||
1 file changed, 8 insertions(+), 7 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/makefile.shared b/makefile.shared
|
|
||||||
index 3955f830..870b18d1 100644
|
|
||||||
--- a/makefile.shared
|
|
||||||
+++ b/makefile.shared
|
|
||||||
@@ -18,6 +18,7 @@ ifndef LIBTOOL
|
|
||||||
endif
|
|
||||||
endif
|
|
||||||
LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC)
|
|
||||||
+LTLINK = $(LIBTOOL) --mode=link --tag=CC $(CC)
|
|
||||||
|
|
||||||
LCOV_ARGS=--directory .libs --directory .
|
|
||||||
|
|
||||||
@@ -59,7 +60,7 @@ objs: $(OBJECTS)
|
|
||||||
LOBJECTS = $(OBJECTS:.o=.lo)
|
|
||||||
|
|
||||||
$(LIBNAME): $(OBJECTS)
|
|
||||||
- $(LIBTOOL) --mode=link --tag=CC $(CC) $(LDFLAGS) $(LOBJECTS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_SO) $(LIBTOOLFLAGS)
|
|
||||||
+ $(LTLINK) $(LDFLAGS) $(LOBJECTS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_SO) $(LIBTOOLFLAGS)
|
|
||||||
|
|
||||||
install: $(LIBNAME)
|
|
||||||
install -d $(DESTDIR)$(LIBPATH)
|
|
||||||
@@ -76,16 +77,16 @@ uninstall:
|
|
||||||
rm $(DESTDIR)$(LIBPATH)/pkgconfig/libtommath.pc
|
|
||||||
|
|
||||||
test: $(LIBNAME) demo/demo.o
|
|
||||||
- $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
|
|
||||||
- $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
|
|
||||||
+ $(LTCOMPILE) $(CFLAGS) -c demo/demo.c -o demo/demo.o
|
|
||||||
+ $(LTLINK) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
|
|
||||||
|
|
||||||
test_standalone: $(LIBNAME) demo/demo.o
|
|
||||||
- $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
|
|
||||||
- $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
|
|
||||||
+ $(LTCOMPILE) $(CFLAGS) -c demo/demo.c -o demo/demo.o
|
|
||||||
+ $(LTLINK) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
|
|
||||||
|
|
||||||
.PHONY: mtest
|
|
||||||
mtest:
|
|
||||||
- cd mtest ; $(CC) $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
|
|
||||||
+ cd mtest ; $(CC) $(CFLAGS) -O0 mtest.c $(LDFLAGS) -o mtest
|
|
||||||
|
|
||||||
timing: $(LIBNAME) demo/timing.c
|
|
||||||
- $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o timing
|
|
||||||
+ $(LTLINK) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o timing
|
|
Reference in New Issue