From cd1ae48aedb40610da43c9deb31311d4e76702f2 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Wed, 3 Jan 2024 09:50:32 +0200
Subject: [PATCH] gnu: Add rust-gix-traverse-0.34.

* gnu/packages/crates-vcs.scm (rust-gix-traverse-0.34): New variable.
(rust-gix-traverse-0.33): Inherit from rust-gix-traverse-0.34.

Change-Id: I79c766419df104d4059d826bd4cff70d625397c9
---
 gnu/packages/crates-vcs.scm | 36 +++++++++++++++++++++++++++++-------
 1 file changed, 29 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/crates-vcs.scm b/gnu/packages/crates-vcs.scm
index a80666b22e..bf1f54a1f3 100644
--- a/gnu/packages/crates-vcs.scm
+++ b/gnu/packages/crates-vcs.scm
@@ -2838,8 +2838,36 @@ provides an implementation of the Git transport layer.")
         ("rust-blocking" ,rust-blocking-1)
         ("rust-maybe-async" ,rust-maybe-async-0.2))))))
 
+(define-public rust-gix-traverse-0.34
+  (package
+    (name "rust-gix-traverse")
+    (version "0.34.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "gix-traverse" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "12pk1w89kj978jdfsg2fwmq5p4gv0i0wydh6pxmbf6sfgpn51l0l"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-gix-commitgraph" ,rust-gix-commitgraph-0.22)
+                       ("rust-gix-date" ,rust-gix-date-0.8)
+                       ("rust-gix-hash" ,rust-gix-hash-0.13)
+                       ("rust-gix-hashtable" ,rust-gix-hashtable-0.4)
+                       ("rust-gix-object" ,rust-gix-object-0.38)
+                       ("rust-gix-revwalk" ,rust-gix-revwalk-0.9)
+                       ("rust-smallvec" ,rust-smallvec-1)
+                       ("rust-thiserror" ,rust-thiserror-1))))
+    (home-page "https://github.com/Byron/gitoxide")
+    (synopsis "Ways to traverse Git commit graphs and trees for Gix")
+    (description "Part of Gitoxide, a pure Rust implementation of Git.  This
+package is used to traverse Git commit graphs and trees.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-gix-traverse-0.33
   (package
+    (inherit rust-gix-traverse-0.34)
     (name "rust-gix-traverse")
     (version "0.33.0")
     (source
@@ -2849,7 +2877,6 @@ provides an implementation of the Git transport layer.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "180vp1piwlalsv8qkmmif03l7h2kdxfx5vawkclbmb236smh9vr2"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs (("rust-gix-commitgraph" ,rust-gix-commitgraph-0.21)
                        ("rust-gix-date" ,rust-gix-date-0.8)
@@ -2858,12 +2885,7 @@ provides an implementation of the Git transport layer.")
                        ("rust-gix-object" ,rust-gix-object-0.37)
                        ("rust-gix-revwalk" ,rust-gix-revwalk-0.8)
                        ("rust-smallvec" ,rust-smallvec-1)
-                       ("rust-thiserror" ,rust-thiserror-1))))
-    (home-page "https://github.com/Byron/gitoxide")
-    (synopsis "Ways to traverse Git commit graphs and trees for Gix")
-    (description "Part of Gitoxide, a pure Rust implementation of Git.  This
-package is used to traverse Git commit graphs and trees.")
-    (license (list license:expat license:asl2.0))))
+                       ("rust-thiserror" ,rust-thiserror-1))))))
 
 (define-public rust-gix-traverse-0.26
   (package