gnu: libdrm-symbol-check.patch: Add case for radeon.
* gnu/packages/patches/libdrm-symbol-check.patch: Add the extra seven symbols from the public headers to the radeon-symbol-check to satisfy the test. Also add aarch64-linux to the list of architectures affected.master
parent
7ed7be3c2e
commit
cec21d689d
|
@ -1,5 +1,5 @@
|
|||
Augment the list of expected symbols to fix the symbol-check tests on
|
||||
mips64el-linux and armhf-linux.
|
||||
mips64el-linux, armhf-linux and aarch64-linux.
|
||||
|
||||
--- libdrm-2.4.65/freedreno/freedreno-symbol-check.orig 2015-09-04 11:07:40.000000000 -0400
|
||||
+++ libdrm-2.4.65/freedreno/freedreno-symbol-check 2015-10-18 23:57:15.288416229 -0400
|
||||
|
@ -193,3 +193,28 @@ mips64el-linux and armhf-linux.
|
|||
drm_tegra_bo_get_flags
|
||||
drm_tegra_bo_get_handle
|
||||
drm_tegra_bo_get_tiling
|
||||
|
||||
--- libdrm-2.4.65/radeon/radeon-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400
|
||||
+++ libdrm-2.4.65/radeon/radeon-symbol-check 2015-10-18 23:57:00.756759698 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
|
||||
-# The following symbols (past the first five) are taken from the public headers.
|
||||
+# The following symbols (past the first 12) are taken from the public headers.
|
||||
# A list of the latter should be available Makefile.sources/LIBDRM_RADEON_H_FILES
|
||||
|
||||
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_tegra.so} | awk '{print $3}'| while read func; do
|
||||
@@ -10,6 +10,13 @@
|
||||
_end
|
||||
_fini
|
||||
_init
|
||||
+_fbss
|
||||
+_fdata
|
||||
+_ftext
|
||||
+__bss_start__
|
||||
+__bss_end__
|
||||
+_bss_end__
|
||||
+__end__
|
||||
radeon_bo_debug
|
||||
radeon_bo_get_handle
|
||||
radeon_bo_get_src_domain
|
||||
|
|
Reference in New Issue