gnu: nss: Increase test timeouts.
* gnu/packages/patches/nss-increase-test-timeout.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnuzilla.scm (nss)[source]: Use it.master
parent
1461dd2410
commit
d027b0011f
|
@ -781,6 +781,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ninja-tests.patch \
|
||||
%D%/packages/patches/ninja-zero-mtime.patch \
|
||||
%D%/packages/patches/node-9077.patch \
|
||||
%D%/packages/patches/nss-increase-test-timeout.patch \
|
||||
%D%/packages/patches/nss-pkgconfig.patch \
|
||||
%D%/packages/patches/ntfs-3g-CVE-2017-0358.patch \
|
||||
%D%/packages/patches/nvi-assume-preserve-path.patch \
|
||||
|
|
|
@ -200,7 +200,8 @@ in the Mozilla clients.")
|
|||
(base32
|
||||
"149807rmzb76hnh48rw4m9jw83iw0168njzchz0hmbsgc8mk0i5w"))
|
||||
;; Create nss.pc and nss-config.
|
||||
(patches (search-patches "nss-pkgconfig.patch"))))
|
||||
(patches (search-patches "nss-pkgconfig.patch"
|
||||
"nss-increase-test-timeout.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs '("out" "bin"))
|
||||
(arguments
|
||||
|
|
|
@ -0,0 +1,25 @@
|
|||
We've seen some tests take more than 20s to complete on a busy armhf
|
||||
machine. Even a busy x86_64 machine can use more than 5s on some tests.
|
||||
|
||||
Increase timeouts to increase chances of a successful build.
|
||||
|
||||
--- a/nss/gtests/ssl_gtest/tls_connect.cc 2017-03-14 22:47:30.855813629 +0100
|
||||
+++ b/nss/gtests/ssl_gtest/tls_connect.cc 2017-03-14 22:48:49.042335273 +0100
|
||||
@@ -245,7 +245,7 @@
|
||||
|
||||
ASSERT_TRUE_WAIT((client_->state() != TlsAgent::STATE_CONNECTING) &&
|
||||
(server_->state() != TlsAgent::STATE_CONNECTING),
|
||||
- 5000);
|
||||
+ 25000);
|
||||
}
|
||||
|
||||
void TlsConnectTestBase::EnableExtendedMasterSecret() {
|
||||
@@ -387,7 +387,7 @@
|
||||
} else {
|
||||
fail_agent = server_;
|
||||
}
|
||||
- ASSERT_TRUE_WAIT(fail_agent->state() == TlsAgent::STATE_ERROR, 5000);
|
||||
+ ASSERT_TRUE_WAIT(fail_agent->state() == TlsAgent::STATE_ERROR, 25000);
|
||||
}
|
||||
|
||||
void TlsConnectTestBase::ConfigureVersion(uint16_t version) {
|
Reference in New Issue