me
/
guix
Archived
1
0
Fork 0

gnu: glibc-for-bootstrap: Refresh patch.

This is a follow-up to d2a01e3b5b.

* gnu/packages/patches/glibc-bootstrap-system.patch: Update for glibc-2.32.
master
Efraim Flashner 2020-09-21 18:33:38 +03:00
parent dd36f508d5
commit d08f5299e6
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
1 changed files with 15 additions and 12 deletions

View File

@ -3,17 +3,8 @@ and popen(3) need to be tweaked to use the right shell. For the bootstrap
glibc, we just use whatever `sh' can be found in $PATH. The final glibc
instead uses the hard-coded absolute file name of `bash'.
--- a/sysdeps/posix/system.c
+++ b/sysdeps/posix/system.c
@@ -140,7 +140,7 @@ do_system (const char *line)
__posix_spawnattr_setflags (&spawn_attr,
POSIX_SPAWN_SETSIGDEF | POSIX_SPAWN_SETSIGMASK);
- status = __posix_spawn (&pid, SHELL_PATH, 0, &spawn_attr,
+ status = posix_spawnp (&pid, SHELL_NAME, 0, &spawn_attr,
(char *const[]){ (char*) SHELL_NAME,
(char*) "-c",
(char *) line, NULL },
diff --git a/libio/iopopen.c b/libio/iopopen.c
index ebc381ed..e0d3ed1b 100644
--- a/libio/iopopen.c
+++ b/libio/iopopen.c
@@ -85,7 +85,7 @@ spawn_process (posix_spawn_file_actions_t *fa, FILE *fp, const char *command,
@ -25,4 +16,16 @@ instead uses the hard-coded absolute file name of `bash'.
(char *const[]){ (char*) "sh", (char*) "-c",
(char *) command, NULL }, __environ) != 0)
return false;
diff --git a/sysdeps/posix/system.c b/sysdeps/posix/system.c
index a03f478f..9530404e 100644
--- a/sysdeps/posix/system.c
+++ b/sysdeps/posix/system.c
@@ -145,7 +145,7 @@ do_system (const char *line)
__posix_spawnattr_setflags (&spawn_attr,
POSIX_SPAWN_SETSIGDEF | POSIX_SPAWN_SETSIGMASK);
- ret = __posix_spawn (&pid, SHELL_PATH, 0, &spawn_attr,
+ ret = posix_spawnp (&pid, SHELL_NAME, 0, &spawn_attr,
(char *const[]){ (char *) SHELL_NAME,
(char *) "-c",
(char *) line, NULL },