From d17c403115463f02546d9ee241ab6482e5979042 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Sergio=20Pastor=20P=C3=A9rez?=
 <sergio.pastorperez@outlook.es>
Date: Wed, 20 Sep 2023 23:27:50 +0200
Subject: [PATCH] gnu: Add dexy-color-sddm-theme.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/display-managers.scm (dexy-color-sddm-theme): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/display-managers.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 4c46abf7af..935563c94c 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -168,6 +168,32 @@ create smooth, animated user interfaces.")
 background with abstract shapes. Inspired by solarized-sddm-theme.")
       (license license:gpl3+))))
 
+(define-public dexy-color-sddm-theme
+  (let ((commit "7929384dbb9305e6da53a8942bca3d75593fd99f")
+        (revision "0"))
+    (package
+      (name "dexy-color-sddm-theme")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/L4ki/Dexy-Plasma-Themes")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1dcp3pvs6x63740sz852yr19fjrdnh81dbrq7rssgm6ssi1rqjig"))))
+      (build-system copy-build-system)
+      (arguments
+       `(#:install-plan '(("Dexy-Color-SDDM"
+                           "/share/sddm/themes/dexy-color-sddm"))))
+      (home-page "https://github.com/L4ki/Dexy-Plasma-Themes")
+      (synopsis "Dexy Color theme for SDDM")
+      (description
+       "This package provides a minimalistic and modern SDDM theme with blured
+background.")
+      (license license:gpl3+))))
+
 (define-public guix-simplyblack-sddm-theme
   (package
     (name "guix-simplyblack-sddm-theme")