me
/
guix
Archived
1
0
Fork 0

gnu: doxygen: Fix build with GCC-12.

* gnu/packages/patches/doxygen-support-gcc-12.patch: New file.
* gnu/local.mk: Add it.
* gnu/packages/documentation.scm (doxygen)[source]: Add patch.

Signed-off-by: Marius Bakke <marius@gnu.org>
master
Greg Hogan 2022-07-28 20:25:28 +00:00 committed by Marius Bakke
parent 35db5d5ca4
commit d5a122921a
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 19 additions and 1 deletions

View File

@ -1014,6 +1014,7 @@ dist_patch_DATA = \
%D%/packages/patches/doc++-include-directives.patch \
%D%/packages/patches/doc++-segfault-fix.patch \
%D%/packages/patches/dovecot-trees-support-dovecot-2.3.patch \
%D%/packages/patches/doxygen-support-gcc-12.patch \
%D%/packages/patches/dstat-fix-crash-when-specifying-delay.patch \
%D%/packages/patches/dstat-skip-devices-without-io.patch \
%D%/packages/patches/dvd+rw-tools-add-include.patch \

View File

@ -198,7 +198,9 @@ markup) can be customized and extended by the user.")
".src.tar.gz")))
(sha256
(base32
"0dqzgci82z950pzg6cpxvvqwybi2031flml3pj47hayhq3c9qpm1"))))
"0dqzgci82z950pzg6cpxvvqwybi2031flml3pj47hayhq3c9qpm1"))
;; Remove with next release.
(patches (search-patches "doxygen-support-gcc-12.patch"))))
(build-system cmake-build-system)
(native-inputs
(list bison

View File

@ -0,0 +1,15 @@
Fix for https://github.com/doxygen/doxygen/issues/9312 made in unreleased upstream commit
https://github.com/doxygen/doxygen/commit/5198966c8d5fec89116d025c74934ac03ea511fa
diff --git a/src/cache.h b/src/cache.h
index 0ff3092ed5..e218eb27d2 100644
--- a/src/cache.h
+++ b/src/cache.h
@@ -19,6 +19,7 @@
#include <list>
#include <unordered_map>
#include <mutex>
+#include <utility>
#include <ctype.h>
/*! Fixed size cache for value type V using keys of type K.