gnu: wmfire: Fix build.
* gnu/packages/gnustep.scm (wmfire)[source]: Add patch. * gnu/packages/patches/wmfire-dont-inline-draw-fire.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I3e937c5e9dbd8a5e2eebfd92213407d9477a47abmaster
parent
ae1873558c
commit
d5d2963826
|
@ -2204,6 +2204,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/websocketpp-fix-for-cmake-3.15.patch \
|
%D%/packages/patches/websocketpp-fix-for-cmake-3.15.patch \
|
||||||
%D%/packages/patches/wlroots-hwdata-fallback.patch \
|
%D%/packages/patches/wlroots-hwdata-fallback.patch \
|
||||||
%D%/packages/patches/wmctrl-64-fix.patch \
|
%D%/packages/patches/wmctrl-64-fix.patch \
|
||||||
|
%D%/packages/patches/wmfire-dont-inline-draw-fire.patch \
|
||||||
%D%/packages/patches/wmfire-update-for-new-gdk-versions.patch \
|
%D%/packages/patches/wmfire-update-for-new-gdk-versions.patch \
|
||||||
%D%/packages/patches/wordnet-CVE-2008-2149.patch \
|
%D%/packages/patches/wordnet-CVE-2008-2149.patch \
|
||||||
%D%/packages/patches/wordnet-CVE-2008-3908-pt1.patch \
|
%D%/packages/patches/wordnet-CVE-2008-3908-pt1.patch \
|
||||||
|
|
|
@ -320,7 +320,8 @@ display, and can run a user-specified program on mouse click.")
|
||||||
(base32
|
(base32
|
||||||
"101grahd80n97y2dczb629clmcgiavdpbbwy78kk5wgs362m12z3"))
|
"101grahd80n97y2dczb629clmcgiavdpbbwy78kk5wgs362m12z3"))
|
||||||
(patches
|
(patches
|
||||||
(search-patches "wmfire-update-for-new-gdk-versions.patch"))))
|
(search-patches "wmfire-dont-inline-draw-fire.patch"
|
||||||
|
"wmfire-update-for-new-gdk-versions.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs
|
(inputs
|
||||||
(list gtk+-2 libgtop))
|
(list gtk+-2 libgtop))
|
||||||
|
|
|
@ -0,0 +1,33 @@
|
||||||
|
https://sources.debian.org/data/main/w/wmfire/1.2.4-7/debian/patches/08_removed-inline-from-function-with-extern-linkage.patch
|
||||||
|
|
||||||
|
Description: remove inline from function with extern linkage
|
||||||
|
Fixes FTBFS with gcc 9.
|
||||||
|
Author: Jeremy Sowden <jeremy@azazel.net>
|
||||||
|
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=925858
|
||||||
|
Last-Update: 2019-06-22
|
||||||
|
Forwarded: not-needed
|
||||||
|
|
||||||
|
---
|
||||||
|
src/wmfire.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
--- a/src/wmfire.c
|
||||||
|
+++ b/src/wmfire.c
|
||||||
|
@@ -111,7 +111,7 @@
|
||||||
|
void change_flame(int);
|
||||||
|
GdkCursor *setup_cursor();
|
||||||
|
void burn_spot(int, int, int);
|
||||||
|
-inline void draw_fire(unsigned int);
|
||||||
|
+void draw_fire(unsigned int);
|
||||||
|
static void make_wmfire_dockapp();
|
||||||
|
void read_config(int, char **);
|
||||||
|
void do_help(void);
|
||||||
|
@@ -504,7 +504,7 @@
|
||||||
|
/* Draw fire */
|
||||||
|
/******************************************/
|
||||||
|
|
||||||
|
-inline void
|
||||||
|
+void
|
||||||
|
draw_fire(unsigned int load)
|
||||||
|
{
|
||||||
|
int x, y, i, j;
|
Reference in New Issue