me
/
guix
Archived
1
0
Fork 0

gnu: fp16: Fix build on i686-linux.

* gnu/packages/patches/fp16-implicit-double.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/maths.scm (fp16)[source](patches): Add it.
master
Marius Bakke 2022-10-15 23:25:42 +02:00
parent 5d58d20684
commit d799c8a5f6
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 26 additions and 1 deletions

View File

@ -1112,6 +1112,7 @@ dist_patch_DATA = \
%D%/packages/patches/foobillard++-pkg-config.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
%D%/packages/patches/fp16-implicit-double.patch \
%D%/packages/patches/fp16-system-libraries.patch \
%D%/packages/patches/fpc-reproducibility.patch \
%D%/packages/patches/freedink-engine-fix-sdl-hints.patch \

View File

@ -7690,7 +7690,8 @@ when an application performs repeated divisions by the same divisor.")
(sha256
(base32
"05mm4vrxsac35hjf5djif9r6rdxj9ippg97ia3p6q6b8lrp7srwv"))
(patches (search-patches "fp16-system-libraries.patch"))))
(patches (search-patches "fp16-implicit-double.patch"
"fp16-system-libraries.patch"))))
(build-system cmake-build-system)
(arguments
`(#:imported-modules ((guix build python-build-system)

View File

@ -0,0 +1,23 @@
Prevent implicit conversion of float to double to avoid precision
error on i686.
https://github.com/Maratyszcza/FP16/issues/20
Taken from Debian:
https://salsa.debian.org/deeplearning-team/fp16/-/blob/master/debian/patches/ftbfs-i386.patch
Index: fp16/include/fp16/fp16.h
===================================================================
--- fp16.orig/include/fp16/fp16.h
+++ fp16/include/fp16/fp16.h
@@ -228,7 +228,8 @@ static inline uint16_t fp16_ieee_from_fp
const float scale_to_inf = fp32_from_bits(UINT32_C(0x77800000));
const float scale_to_zero = fp32_from_bits(UINT32_C(0x08800000));
#endif
- float base = (fabsf(f) * scale_to_inf) * scale_to_zero;
+ const volatile float base_inf = fabsf(f) * scale_to_inf;
+ float base = base_inf * scale_to_zero;
const uint32_t w = fp32_to_bits(f);
const uint32_t shl1_w = w + w;