gnu: GRUB: Adjust to recent binutils changes.
* gnu/packages/patches/grub-binutils-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/bootloaders.scm (grub)[source](patches): Add it.master
parent
8f1022d0a8
commit
d9362003b6
|
@ -771,6 +771,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/grep-timing-sensitive-test.patch \
|
%D%/packages/patches/grep-timing-sensitive-test.patch \
|
||||||
%D%/packages/patches/groff-source-date-epoch.patch \
|
%D%/packages/patches/groff-source-date-epoch.patch \
|
||||||
%D%/packages/patches/groovy-add-exceptionutilsgenerator.patch \
|
%D%/packages/patches/groovy-add-exceptionutilsgenerator.patch \
|
||||||
|
%D%/packages/patches/grub-binutils-compat.patch \
|
||||||
%D%/packages/patches/grub-check-error-efibootmgr.patch \
|
%D%/packages/patches/grub-check-error-efibootmgr.patch \
|
||||||
%D%/packages/patches/gsl-test-i686.patch \
|
%D%/packages/patches/gsl-test-i686.patch \
|
||||||
%D%/packages/patches/gspell-dash-test.patch \
|
%D%/packages/patches/gspell-dash-test.patch \
|
||||||
|
|
|
@ -86,7 +86,8 @@
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"03vvdfhdmf16121v7xs8is2krwnv15wpkhkf16a4yf8nsfc3f2w1"))
|
"03vvdfhdmf16121v7xs8is2krwnv15wpkhkf16a4yf8nsfc3f2w1"))
|
||||||
(patches (search-patches "grub-check-error-efibootmgr.patch"))))
|
(patches (search-patches "grub-check-error-efibootmgr.patch"
|
||||||
|
"grub-binutils-compat.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases (modify-phases %standard-phases
|
`(#:phases (modify-phases %standard-phases
|
||||||
|
|
|
@ -0,0 +1,53 @@
|
||||||
|
Fix a relocation issue that shows up with recent binutils.
|
||||||
|
|
||||||
|
Patch taken from upstream:
|
||||||
|
https://git.sv.gnu.org/cgit/grub.git/commit/?id=842c390469e2c2e10b5aa36700324cd3bde25875
|
||||||
|
|
||||||
|
diff --git a/grub-core/efiemu/i386/loadcore64.c b/grub-core/efiemu/i386/loadcore64.c
|
||||||
|
index e49d0b6..18facf4 100644
|
||||||
|
--- a/grub-core/efiemu/i386/loadcore64.c
|
||||||
|
+++ b/grub-core/efiemu/i386/loadcore64.c
|
||||||
|
@@ -98,6 +98,7 @@ grub_arch_efiemu_relocate_symbols64 (grub_efiemu_segment_t segs,
|
||||||
|
break;
|
||||||
|
|
||||||
|
case R_X86_64_PC32:
|
||||||
|
+ case R_X86_64_PLT32:
|
||||||
|
err = grub_efiemu_write_value (addr,
|
||||||
|
*addr32 + rel->r_addend
|
||||||
|
+ sym.off
|
||||||
|
diff --git a/grub-core/kern/x86_64/dl.c b/grub-core/kern/x86_64/dl.c
|
||||||
|
index 4406906..3a73e6e 100644
|
||||||
|
--- a/grub-core/kern/x86_64/dl.c
|
||||||
|
+++ b/grub-core/kern/x86_64/dl.c
|
||||||
|
@@ -70,6 +70,7 @@ grub_arch_dl_relocate_symbols (grub_dl_t mod, void *ehdr,
|
||||||
|
break;
|
||||||
|
|
||||||
|
case R_X86_64_PC32:
|
||||||
|
+ case R_X86_64_PLT32:
|
||||||
|
{
|
||||||
|
grub_int64_t value;
|
||||||
|
value = ((grub_int32_t) *addr32) + rel->r_addend + sym->st_value -
|
||||||
|
diff --git a/util/grub-mkimagexx.c b/util/grub-mkimagexx.c
|
||||||
|
index a2bb054..39d7efb 100644
|
||||||
|
--- a/util/grub-mkimagexx.c
|
||||||
|
+++ b/util/grub-mkimagexx.c
|
||||||
|
@@ -841,6 +841,7 @@ SUFFIX (relocate_addresses) (Elf_Ehdr *e, Elf_Shdr *sections,
|
||||||
|
break;
|
||||||
|
|
||||||
|
case R_X86_64_PC32:
|
||||||
|
+ case R_X86_64_PLT32:
|
||||||
|
{
|
||||||
|
grub_uint32_t *t32 = (grub_uint32_t *) target;
|
||||||
|
*t32 = grub_host_to_target64 (grub_target_to_host32 (*t32)
|
||||||
|
diff --git a/util/grub-module-verifier.c b/util/grub-module-verifier.c
|
||||||
|
index 9179285..a79271f 100644
|
||||||
|
--- a/util/grub-module-verifier.c
|
||||||
|
+++ b/util/grub-module-verifier.c
|
||||||
|
@@ -19,6 +19,7 @@ struct grub_module_verifier_arch archs[] = {
|
||||||
|
-1
|
||||||
|
}, (int[]){
|
||||||
|
R_X86_64_PC32,
|
||||||
|
+ R_X86_64_PLT32,
|
||||||
|
-1
|
||||||
|
}
|
||||||
|
},
|
Reference in New Issue