From da2f9c95ab021c3db47e525b88a0f37772c04b45 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Fri, 29 Apr 2022 21:24:55 -0400
Subject: [PATCH] gnu: Remove python2-serpent.

* gnu/packages/python-xyz.scm (python2-serpent): Delete variable.
---
 gnu/packages/python-xyz.scm | 8 --------
 1 file changed, 8 deletions(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b78a497cb5..2ef1e24248 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1903,16 +1903,8 @@ to rebuild the original object tree.
 
 Because only safe literals are encoded, it is safe to send serpent data to
 other machines, such as over the network.")
-    (properties `((python2-variant . ,(delay python2-serpent))))
     (license license:expat)))
 
-(define-public python2-serpent
-  (let ((base (package-with-python2 (strip-python2-variant python-serpent))))
-    (package/inherit base
-      (propagated-inputs
-       `(("python-enum34" ,python2-enum34)
-         ,@(package-propagated-inputs base))))))
-
 (define-public python-setuptools
   (package
     (name "python-setuptools")