me
/
guix
Archived
1
0
Fork 0

gnu: brightnessctl: Add elogind support.

* gnu/packages/patches/brightnessctl-elogind-support.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/linux.scm (brightnessctl)[source]: Apply it.
[make-flags]: Enable logind support.
[native-inputs]: Add pkg-config.
[inputs]: Add elogind.
master
Brice Waegeneire 2021-06-04 20:42:28 +02:00
parent 375d5d03c9
commit db87a223fe
No known key found for this signature in database
GPG Key ID: A94903A166A18FAE
3 changed files with 23 additions and 4 deletions

View File

@ -852,6 +852,7 @@ dist_patch_DATA = \
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
%D%/packages/patches/bc-fix-cross-compilation.patch \
%D%/packages/patches/bear-disable-preinstall-tests.patch \
%D%/packages/patches/brightnessctl-elogind-support.patch \
%D%/packages/patches/bsdiff-CVE-2014-9862.patch \
%D%/packages/patches/bsd-games-2.17-64bit.patch \
%D%/packages/patches/bsd-games-add-configure-config.patch \

View File

@ -36,14 +36,13 @@
;;; Copyright © 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Stefan Stefanović <stefanx2ovic@gmail.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019, 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2019, 2020, 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
@ -6413,13 +6412,15 @@ set the screen to be pitch black at a value of 0 (or higher).
(file-name (git-file-name name version))
(sha256
(base32
"0immxc7almmpg80n3bdn834p3nrrz7bspl2syhb04s3lawa5y2lq"))))
"0immxc7almmpg80n3bdn834p3nrrz7bspl2syhb04s3lawa5y2lq"))
(patches (search-patches "brightnessctl-elogind-support.patch"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
#:make-flags (list (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" %output)
(string-append "UDEVDIR=" %output "/lib/udev/rules.d/"))
(string-append "UDEVDIR=" %output "/lib/udev/rules.d/")
"ENABLE_SYSTEMD=1")
#:phases
(modify-phases %standard-phases
(delete 'configure)
@ -6428,6 +6429,10 @@ set the screen to be pitch black at a value of 0 (or higher).
(substitute* "90-brightnessctl.rules"
(("/bin/") "/run/current-system/profile/bin/"))
#t)))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
`(("elogind" ,elogind)))
(synopsis "Backlight and LED brightness control")
(description
"This program allows you read and control device brightness. Devices

View File

@ -0,0 +1,13 @@
From https://github.com/Hummer12007/brightnessctl/issues/67
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,8 @@ MODE = ${MODE_${INSTALL_UDEV_RULES}}
ifdef ENABLE_SYSTEMD
CFLAGS += ${shell pkg-config --cflags libsystemd}
LDLIBS += ${shell pkg-config --libs libsystemd}
+ CFLAGS += ${shell pkg-config --cflags libelogind}
+ LDLIBS += ${shell pkg-config --libs libelogind}
CPPFLAGS += -DENABLE_SYSTEMD
INSTALL_UDEV_RULES=0
MODE = 0755