me
/
guix
Archived
1
0
Fork 0

gnu: python-testtools: Update to 2.5.0.

* gnu/packages/check.scm (python-testtools): Update to 2.5.0.
[propagated-inputs]: Remove python-mimeparse, python-pbr, python-six,
python-traceback2, python-unittest2.
(python-testtools-bootstrap)[source]: Remove patch.
* gnu/packages/patches/python-testtools.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Efraim Flashner 2021-08-11 16:16:51 +03:00
parent 5037b08b93
commit db8e8eb171
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 4 additions and 71 deletions

View File

@ -1612,7 +1612,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-mediafile-wavpack.patch \
%D%/packages/patches/python-memcached-syntax-warnings.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-testtools.patch \
%D%/packages/patches/python-typing-inspect-fix.patch \
%D%/packages/patches/python-packaging-test-arch.patch \
%D%/packages/patches/python2-parameterized-docstring-test.patch \

View File

@ -1404,25 +1404,20 @@ subprocess and see the output as well as any file modifications.")
(define-public python-testtools-bootstrap
(package
(name "python-testtools-bootstrap")
(version "2.3.0")
(version "2.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "testtools" version))
(sha256
(base32
"0n8519lk8aaa91vymz842831181wf7fss98hyllhygi3z1nfq9sq"))
(patches (search-patches "python-testtools.patch"))))
"0gxjbjk93jjqi491k4s9rh3ia37v21yifd35pvizv7sgv4rk9hap"))))
(build-system python-build-system)
(arguments '(#:tests? #f))
(propagated-inputs
`(("python-extras" ,python-extras)
("python-fixtures" ,python-fixtures-bootstrap)
("python-mimeparse" ,python-mimeparse)
("python-pbr" ,python-pbr-minimal)
("python-six" ,python-six)
("python-traceback2" ,python-traceback2)
("python-unittest2" ,python-unittest2)))
("python-pbr" ,python-pbr-minimal)))
(home-page "https://github.com/testing-cabal/testtools")
(synopsis
"Extensions to the Python standard library unit testing framework")
@ -1443,11 +1438,7 @@ subprocess and see the output as well as any file modifications.")
(propagated-inputs
`(("python-extras" ,python-extras)
("python-fixtures" ,python-fixtures)
("python-mimeparse" ,python-mimeparse)
("python-pbr" ,python-pbr)
("python-six" ,python-six)
("python-traceback2" ,python-traceback2)
("python-unittest2" ,python-unittest2)))
("python-pbr" ,python-pbr)))
(native-inputs
`(("python-testscenarios" ,python-testscenarios-bootstrap)))
(description

View File

@ -1,57 +0,0 @@
https://github.com/testing-cabal/testtools/commit/29004731f9c480b7c44a9c2605513d50d372898f.patch
Should be fixed in the next release
From 29004731f9c480b7c44a9c2605513d50d372898f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Thu, 17 May 2018 17:52:26 +0200
Subject: [PATCH] Fix the tests on Python 3.7
Exception's repr got changed not to include trailing comma
Fixes https://github.com/testing-cabal/testtools/issues/270
---
.travis.yml | 1 +
testtools/tests/matchers/test_exception.py | 11 +++++++++--
2 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/.travis.yml b/.travis.yml
index 7f1f4db7..784608e0 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,6 +5,7 @@ python:
- "3.4"
- "3.5"
- "3.6"
+ - "3.7-dev"
- "pypy"
install:
diff --git a/testtools/tests/matchers/test_exception.py b/testtools/tests/matchers/test_exception.py
index 6cd80af1..acd39252 100644
--- a/testtools/tests/matchers/test_exception.py
+++ b/testtools/tests/matchers/test_exception.py
@@ -32,15 +32,22 @@ class TestMatchesExceptionInstanceInterface(TestCase, TestMatchersInterface):
matches_matches = [error_foo]
matches_mismatches = [error_bar, error_base_foo]
+ if sys.version_info >= (3, 7):
+ # exception's repr has changed
+ _e = ''
+ else:
+ _e = ','
+
str_examples = [
- ("MatchesException(Exception('foo',))",
+ ("MatchesException(Exception('foo'%s))" % _e,
MatchesException(Exception('foo')))
]
describe_examples = [
("%r is not a %r" % (Exception, ValueError),
error_base_foo,
MatchesException(ValueError("foo"))),
- ("ValueError('bar',) has different arguments to ValueError('foo',).",
+ ("ValueError('bar'%s) has different arguments to ValueError('foo'%s)."
+ % (_e, _e),
error_bar,
MatchesException(ValueError("foo"))),
]