me
/
guix
Archived
1
0
Fork 0

gnu: Add qemu-7.2.4.

Version 8.0.5 is the latest version that works reliably as a
qemu-binfmt-service for riscv64, which makes 7.2.4 the newest working version
that was packaged for Guix.

* gnu/packages/patches/qemu-7.2.4-build-info-manual.patch,
gnu/packages/patches/qemu-disable-aarch64-migration-test.patch: New files.
* gnu/local.mk (dist_patch_DATA): Register them.
* gnu/packages/virtualization.scm (qemu-7.2.4): Use them in new package.

Change-Id: Iaedc424e619cdc4964945f7383d47cff0c7ed10f
master
Janneke Nieuwenhuizen 2024-06-03 15:11:21 +02:00
parent 40c6f70839
commit dbab132224
No known key found for this signature in database
GPG Key ID: F3C1A0D9C1D65273
4 changed files with 101 additions and 0 deletions

View File

@ -1981,7 +1981,9 @@ dist_patch_DATA = \
%D%/packages/patches/python-waitress-fix-tests.patch \
%D%/packages/patches/python-werkzeug-tests.patch \
%D%/packages/patches/python-zeep-Fix-pytest_httpx-test-cases.patch \
%D%/packages/patches/qemu-7.2.4-build-info-manual.patch \
%D%/packages/patches/qemu-build-info-manual.patch \
%D%/packages/patches/qemu-disable-aarch64-migration-test.patch \
%D%/packages/patches/qemu-disable-bios-tables-test.patch \
%D%/packages/patches/qemu-glibc-2.27.patch \
%D%/packages/patches/qemu-glibc-2.30.patch \

View File

@ -0,0 +1,62 @@
From 2793f47c066ed396b38893c10533202fceb1a05f Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Thu, 17 Sep 2020 13:28:19 -0400
Subject: [PATCH] build: Build and install a Texinfo version of the manual.
Take advantage of the Sphinx texinfo backend to generate a QEMU info
manual. The Texinfo format allows for more structure and info readers
provide more advanced navigation capabilities compared to manpages
readers.
* docs/meson.build (texi, info): New targets.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
diff --git a/docs/meson.build b/docs/meson.build
--- a/docs/meson.build
+++ b/docs/meson.build
@@ -92,4 +92,25 @@ if build_docs
alias_target('sphinxdocs', sphinxdocs)
alias_target('html', sphinxdocs)
alias_target('man', sphinxmans)
+
+ # Generate a Texinfo version of the QEMU manual.
+ makeinfo = find_program(['texi2any', 'makeinfo'])
+ if makeinfo.found()
+ sphinxtexi = custom_target(
+ 'QEMU manual generated texinfo source',
+ output: ['QEMU.texi', 'sphinxtexi.stamp'],
+ depfile: 'sphinxtexi.d',
+ command: [SPHINX_ARGS, '-Ddepfile=@DEPFILE@',
+ '-Ddepfile_stamp=@OUTPUT1@', '-b', 'texinfo',
+ meson.current_source_dir(), meson.current_build_dir()])
+ sphinxinfo = custom_target(
+ 'QEMU info manual',
+ input: sphinxtexi,
+ output: 'QEMU.info',
+ install: true,
+ install_dir: get_option('infodir'),
+ command: [makeinfo, '--no-split', '@INPUT0@', '--output=@OUTPUT@'])
+ alias_target('texi', sphinxtexi)
+ alias_target('info', sphinxinfo)
+ endif
endif
diff --git a/meson.build b/meson.build
--- a/meson.build
+++ b/meson.build
@@ -37,6 +37,7 @@ endif
qemu_confdir = get_option('sysconfdir') / get_option('qemu_suffix')
qemu_datadir = get_option('datadir') / get_option('qemu_suffix')
qemu_docdir = get_option('docdir') / get_option('qemu_suffix')
+qemu_infodir = get_option('infodir') / get_option('qemu_suffix')
qemu_moddir = get_option('libdir') / get_option('qemu_suffix')
qemu_desktopdir = get_option('datadir') / 'applications'
@@ -3698,6 +3699,7 @@ else
summary_info += {'local state directory': 'queried at runtime'}
endif
summary_info += {'Doc directory': get_option('prefix') / get_option('docdir')}
+summary_info += {'Info directory': get_option('prefix') / get_option('infodir')}
summary_info += {'Build directory': meson.current_build_dir()}
summary_info += {'Source path': meson.current_source_dir()}
summary_info += {'GIT submodules': config_host['GIT_SUBMODULES']}

View File

@ -0,0 +1,13 @@
Disable the qtest-aarch64/migration-test, which sometimes fail non-deterministically.
See: https://gitlab.com/qemu-project/qemu/-/issues/1230.
--- qemu-7.1.0/tests/qtest/meson.build.old 1969-12-31 19:00:01.000000000 -0500
+++ qemu-7.1.0/tests/qtest/meson.build 2022-09-26 11:11:05.434209797 -0400
@@ -219,7 +219,6 @@
['arm-cpu-features',
'numa-test',
'boot-serial-test',
- 'migration-test',
'bcm2835-dma-test']
qtests_s390x = \

View File

@ -32,6 +32,7 @@
;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023, 2024 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -520,6 +521,29 @@ server and embedded PowerPC, and S390 guests.")
(supported-systems (fold delete %supported-systems
'("mips64el-linux" "i586-gnu")))))
;; QEMU >= 8.1.0's riscv64 binfmt service is unreliable.
(define-public qemu-7.2.4
(package
(inherit qemu)
(name "qemu")
(version "7.2.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.qemu.org/qemu-"
version ".tar.xz"))
(sha256
(base32 "0795l8xsy67fnh4mbdz40jm880iisd7q6d7ly6nfzpac3gjr8zyf"))
(patches (search-patches "qemu-7.2.4-build-info-manual.patch"
"qemu-disable-aarch64-migration-test.patch"
"qemu-fix-agent-paths.patch"))
(modules (origin-modules (package-source qemu)))
(snippet (origin-snippet (package-source qemu)))))
(arguments
(substitute-keyword-arguments (package-arguments qemu)
((#:tests? tests #f) ;migration tests still fail
#f)))))
(define-public qemu-minimal
;; QEMU without GUI support, only supporting the host's architecture
(package/inherit qemu