me
/
guix
Archived
1
0
Fork 0

gnu: appstream: Update to 1.0.3.

* gnu/packages/freedesktop.scm (appstream): Update to 1.0.3.
[source]: Remove patch.
[native-inputs]: Add gi-docgen.
(appstream-qt)[arguments]: Pass -Dqt-versions=5.
* gnu/packages/patches/appstream-force-reload-stemmer.patch: Delete it.
* gnu/local.mk (dist_patch_DATA): Unregister it.

Change-Id: I7037c0e1b6c8e0d4212506e9caac9fe64a762d96
master
Zheng Junjie 2024-07-05 23:23:57 +08:00
parent 5b1b766291
commit dbe43da6da
No known key found for this signature in database
GPG Key ID: 3B5AA993E1A2DFF0
3 changed files with 9 additions and 99 deletions

View File

@ -949,7 +949,6 @@ dist_patch_DATA = \
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
%D%/packages/patches/antlr3-3_3-fix-java8-compilation.patch \
%D%/packages/patches/aoflagger-use-system-provided-pybind11.patch \
%D%/packages/patches/appstream-force-reload-stemmer.patch \
%D%/packages/patches/apr-fix-atomics.patch \
%D%/packages/patches/apr-skip-getservbyname-test.patch \
%D%/packages/patches/aria2-unbundle-wslay.patch \

View File

@ -143,7 +143,7 @@
(define-public appstream
(package
(name "appstream")
(version "0.16.4")
(version "1.0.3")
(source
(origin
(method url-fetch)
@ -152,9 +152,7 @@
"appstream/releases/"
"AppStream-" version ".tar.xz"))
(sha256
(base32 "1val1b3dggn9g33q2r9q7wsl75a64x4lcvswvkcjjbvakkbj5xyl"))
(patches
(search-patches "appstream-force-reload-stemmer.patch"))))
(base32 "195snvg2jw5ywqxz02xfb570yhxvaqp9d4w5a2lpay2fck7zddjs"))))
(build-system meson-build-system)
(arguments
(list
@ -166,9 +164,9 @@
(lambda* (#:key inputs #:allow-other-keys)
(let ((libstemmer.h (search-input-file inputs
"include/libstemmer.h")))
(substitute* "meson.build"
(("/usr/include")
(dirname libstemmer.h))))))
(substitute* "meson.build"
(("/usr/include")
(dirname libstemmer.h))))))
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd)))))))
@ -184,7 +182,8 @@
itstool
libxslt
pkg-config
python-wrapper))
python-wrapper
gi-docgen))
(inputs
(list curl libsoup-minimal-2 libstemmer libxmlb libxml2 libyaml lmdb))
(propagated-inputs
@ -213,7 +212,8 @@ application-centers for distributions.")
(arguments
(substitute-keyword-arguments (package-arguments appstream)
((#:configure-flags flags #~'())
#~(append '("-Dqt=true") #$flags))))))
#~(append '("-Dqt=true" "-Dqt-versions=5") #$flags))))))
(define-public farstream
(package

View File

@ -1,89 +0,0 @@
From 32182d7a7a67d0d204cd0a37bd211bfd0177bc27 Mon Sep 17 00:00:00 2001
Message-ID: <32182d7a7a67d0d204cd0a37bd211bfd0177bc27.1700093066.git.vivien@planete-kraus.eu>
From: Matthias Klumpp <matthias@tenstral.net>
Date: Thu, 16 Nov 2023 00:59:15 +0100
Subject: [PATCH] stemmer: Resolve potential issue where stemmer may never be
initialized
If the initial locale was equal to the current stemming language, we may
never have initialized the stemmer (which could lead to crashes or
stemming being disabled).
So we force the reload to always happen on initialization.
CC: #558
---
src/as-stemmer.c | 33 +++++++++++++++++++++------------
1 file changed, 21 insertions(+), 12 deletions(-)
diff --git a/src/as-stemmer.c b/src/as-stemmer.c
index 63d45267..16ebd09b 100644
--- a/src/as-stemmer.c
+++ b/src/as-stemmer.c
@@ -47,6 +47,8 @@ G_DEFINE_TYPE (AsStemmer, as_stemmer, G_TYPE_OBJECT)
static gpointer as_stemmer_object = NULL;
+static void as_stemmer_reload_internal (AsStemmer *stemmer, const gchar *locale, gboolean force);
+
/**
* as_stemmer_finalize:
**/
@@ -76,21 +78,14 @@ as_stemmer_init (AsStemmer *stemmer)
/* we don't use the locale in XML, so it can be POSIX */
locale = as_get_current_locale_posix ();
- stemmer->current_lang = as_utils_locale_to_language (locale);
- as_stemmer_reload (stemmer, stemmer->current_lang);
+ /* force a reload for initialization */
+ as_stemmer_reload_internal (stemmer, locale, TRUE);
#endif
}
-/**
- * as_stemmer_reload:
- * @stemmer: A #AsStemmer
- * @locale: The stemming language as POSIX locale.
- *
- * Allows realoading the #AsStemmer with a different language.
- */
-void
-as_stemmer_reload (AsStemmer *stemmer, const gchar *locale)
+static void
+as_stemmer_reload_internal (AsStemmer *stemmer, const gchar *locale, gboolean force)
{
#ifdef HAVE_STEMMING
g_autofree gchar *lang = NULL;
@@ -99,7 +94,7 @@ as_stemmer_reload (AsStemmer *stemmer, const gchar *locale)
/* check if we need to reload */
lang = as_utils_locale_to_language (locale);
locker = g_mutex_locker_new (&stemmer->mutex);
- if (as_str_equal0 (lang, stemmer->current_lang)) {
+ if (!force && as_str_equal0 (lang, stemmer->current_lang)) {
g_mutex_locker_free (locker);
return;
}
@@ -119,6 +114,20 @@ as_stemmer_reload (AsStemmer *stemmer, const gchar *locale)
#endif
}
+/**
+ * as_stemmer_reload:
+ * @stemmer: A #AsStemmer
+ * @locale: The stemming language as POSIX locale.
+ *
+ * Allows realoading the #AsStemmer with a different language.
+ * Does nothing if the stemmer is already using the selected language.
+ */
+void
+as_stemmer_reload (AsStemmer *stemmer, const gchar *locale)
+{
+ as_stemmer_reload_internal (stemmer, locale, FALSE);
+}
+
/**
* as_stemmer_stem:
* @stemmer: A #AsStemmer
--
2.41.0