From dddda7ce43b9d5e7d0695510d585e29a0d1ff78d Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:53:11 +0200
Subject: [PATCH] gnu: Add texlive-isodate.

* gnu/packages/tex.scm (texlive-isodate): New variable.
---
 gnu/packages/tex.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2fce6451b2..a74b14fce0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -85819,6 +85819,30 @@ typesetting the ISO 10303 (STEP) standards.  Standard documents prepared using
 these packages have been published by ISO.")
     (license license:lppl)))
 
+(define-public texlive-isodate
+  (package
+    (name "texlive-isodate")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/isodate/" "source/latex/isodate/"
+                   "tex/latex/isodate/")
+             (base32
+              "0bha4qpa1hi5i4npr00wz4qvzzc4yw4qydjjmm8n878p8cfygvga")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/isodate")
+    (synopsis "Tune the output format of dates according to language")
+    (description
+     "This package provides ten output formats of the commands @code{\\today},
+@code{\\printdate}, @code{\\printdateTeX}, and @code{\\daterange} (partly
+language dependent).  The commands @code{\\printdate} and
+@code{\\printdateTeX} print any date.  The command @code{\\daterange} prints
+a date range and leaves out unnecessary year or month entries.  This package
+supports German (old and new rules), Austrian, US English, British English,
+French, Danish, Swedish, and Norwegian.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar