From de802a7d269885b8df7314273e9b881a5b913de3 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 22 Aug 2023 15:25:16 +0200
Subject: [PATCH] gnu: Add texlive-bjfuthesis.

* gnu/packages/tex.scm (texlive-bjfuthesis): New variable.
---
 gnu/packages/tex.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c52c8256b2..7f8adb225c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6824,6 +6824,26 @@ the Bitter family of fonts.  Bitter is a contemporary slab-serif typeface for
 text.  There are regular and bold weights and an italic, but no bold italic.")
     (license (list license:lppl license:silofl1.1))))
 
+(define-public texlive-bjfuthesis
+  (package
+    (name "texlive-bjfuthesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/bjfuthesis/"
+                   "tex/latex/bjfuthesis/")
+             (base32
+              "0qhb9kighs4ljmnn94qaihpllhwvmi76j3p8yylyjw2hzip102wr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/bjfuthesis")
+    (synopsis "Thesis class for Beijing Forestry University")
+    (description
+     "This is a class file for producing dissertations and theses according to
+the @acronym{BJFU, Beijing Forestry University} guidelines for undergraduate
+theses and dissertations.")
+    (license license:gpl3)))
+
 (define-public texlive-blacklettert1
   (package
     (name "texlive-blacklettert1")