me
/
guix
Archived
1
0
Fork 0

gnu: Remove bsdiff traces.

This is a follow-up to 373c7b5791.

* gnu/packages/patches/bsdiff-CVE-2014-9862.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
master
Marius Bakke 2021-06-19 17:17:02 +02:00
parent 657aaa7be4
commit dece03e2b9
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
2 changed files with 0 additions and 16 deletions

View File

@ -854,7 +854,6 @@ dist_patch_DATA = \
%D%/packages/patches/bc-fix-cross-compilation.patch \
%D%/packages/patches/bear-disable-preinstall-tests.patch \
%D%/packages/patches/brightnessctl-elogind-support.patch \
%D%/packages/patches/bsdiff-CVE-2014-9862.patch \
%D%/packages/patches/bsd-games-2.17-64bit.patch \
%D%/packages/patches/bsd-games-add-configure-config.patch \
%D%/packages/patches/bsd-games-add-wrapper.patch \

View File

@ -1,15 +0,0 @@
diff --git a/bspatch.c b/bspatch.c
index 8d95633..ab77722 100644
--- a/bspatch.c
+++ b/bspatch.c
@@ -187,6 +187,10 @@
};
/* Sanity-check */
+ if ((ctrl[0] < 0) || (ctrl[1] < 0))
+ errx(1,"Corrupt patch\n");
+
+ /* Sanity-check */
if(newpos+ctrl[0]>newsize)
errx(1,"Corrupt patch\n");