gnu: Remove bsdiff traces.
This is a follow-up to 373c7b5791
.
* gnu/packages/patches/bsdiff-CVE-2014-9862.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
master
parent
657aaa7be4
commit
dece03e2b9
|
@ -854,7 +854,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/bc-fix-cross-compilation.patch \
|
||||
%D%/packages/patches/bear-disable-preinstall-tests.patch \
|
||||
%D%/packages/patches/brightnessctl-elogind-support.patch \
|
||||
%D%/packages/patches/bsdiff-CVE-2014-9862.patch \
|
||||
%D%/packages/patches/bsd-games-2.17-64bit.patch \
|
||||
%D%/packages/patches/bsd-games-add-configure-config.patch \
|
||||
%D%/packages/patches/bsd-games-add-wrapper.patch \
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
diff --git a/bspatch.c b/bspatch.c
|
||||
index 8d95633..ab77722 100644
|
||||
--- a/bspatch.c
|
||||
+++ b/bspatch.c
|
||||
|
||||
@@ -187,6 +187,10 @@
|
||||
};
|
||||
|
||||
/* Sanity-check */
|
||||
+ if ((ctrl[0] < 0) || (ctrl[1] < 0))
|
||||
+ errx(1,"Corrupt patch\n");
|
||||
+
|
||||
+ /* Sanity-check */
|
||||
if(newpos+ctrl[0]>newsize)
|
||||
errx(1,"Corrupt patch\n");
|
Reference in New Issue