From dee2a6d2a94684fc7bd7d4efa2b6c7e20ed66c82 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:53:51 +0200
Subject: [PATCH] gnu: Add texlive-latexdemo.

* gnu/packages/tex.scm (texlive-latexdemo): New variable.
---
 gnu/packages/tex.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1ab8542b01..e1acf0a200 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -86699,6 +86699,28 @@ defines the set of colors shown on @url{latexcolor.com} for use in documents
 typeset with LaTeX and friends.")
     (license license:lppl1.3+)))
 
+(define-public texlive-latexdemo
+  (package
+    (name "texlive-latexdemo")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/latexdemo/"
+                   "source/latex/latexdemo/"
+                   "tex/latex/latexdemo/")
+             (base32
+              "0d3bxwcd98n9ij3jikm7zci1j15nhds5nhrk8vifsi04l4wgh8ls")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/latexdemo")
+    (synopsis "Demonstrate LaTeX code with its resulting output")
+    (description
+     "The package provides configurable tools to print out LaTeX code and the
+resulting output in the same document.  It also supports printing the result
+inside a conditional sequence; thus one may suppress printing if the code
+would not compile.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar