gnu: ghostscript: Update to 9.50.
* gnu/packages/ghostscript.scm (ghostscript): Update to 9.50. * gnu/packages/patches/ghostscript-no-header-id.patch: Adjust context.master
parent
c751e5c6bb
commit
e0fb90490e
|
@ -156,7 +156,7 @@ printing, and psresize, for adjusting page sizes.")
|
|||
(define-public ghostscript
|
||||
(package
|
||||
(name "ghostscript")
|
||||
(version "9.27")
|
||||
(version "9.50")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -166,7 +166,7 @@ printing, and psresize, for adjusting page sizes.")
|
|||
"/ghostscript-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"06dnj0mxyaryfbwlsjwaqf847w91w2h8f108kxxcc41nrnx1y3zw"))
|
||||
"1m770dwc82afdgzgq2kar3120r1lbybm3mssdm79f8kggf0v16yv"))
|
||||
(patches (search-patches "ghostscript-no-header-creationdate.patch"
|
||||
"ghostscript-no-header-id.patch"
|
||||
"ghostscript-no-header-uuid.patch"))
|
||||
|
|
|
@ -9,10 +9,10 @@ See: https://bugs.ghostscript.com/show_bug.cgi?id=698208
|
|||
diff -ur orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
|
||||
--- orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c 2017-07-09 23:30:28.960479189 +0200
|
||||
+++ gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c 2017-07-09 23:34:34.306524488 +0200
|
||||
@@ -1785,8 +1785,11 @@
|
||||
@@ -1810,8 +1810,11 @@
|
||||
* +1 for the linearisation dict and +1 for the primary hint stream.
|
||||
*/
|
||||
linear_params->FirsttrailerOffset = gp_ftell_64(linear_params->Lin_File.file);
|
||||
linear_params->FirsttrailerOffset = gp_ftell(linear_params->Lin_File.file);
|
||||
- gs_sprintf(LDict, "\ntrailer\n<</Size %ld/Info %d 0 R/Root %d 0 R/ID[%s%s]/Prev %d>>\nstartxref\r\n0\n%%%%EOF\n \n",
|
||||
- linear_params->LastResource + 3, pdev->ResourceUsage[linear_params->Info_id].NewObjectNumber, pdev->ResourceUsage[linear_params->Catalog_id].NewObjectNumber, fileID, fileID, 0);
|
||||
+ gs_sprintf(LDict, "\ntrailer\n<</Size %ld/Info %d 0 R/Root %d 0 R",
|
||||
|
@ -20,10 +20,10 @@ diff -ur orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c gnu-ghostscript-9.
|
|||
+ if (pdev->OwnerPassword.size > 0 || !(!getenv("GS_GENERATE_UUIDS") || (strcasecmp(getenv("GS_GENERATE_UUIDS"), "0") != 0 && strcasecmp(getenv("GS_GENERATE_UUIDS"), "no") != 0))) /* ID is mandatory when encrypting */
|
||||
+ gs_sprintf(LDict, "/ID[%s%s]", fileID, fileID);
|
||||
+ gs_sprintf(LDict, "/Prev %d>>\nstartxref\r\n0\n%%%%EOF\n \n", 0);
|
||||
fwrite(LDict, strlen(LDict), 1, linear_params->Lin_File.file);
|
||||
gp_fwrite(LDict, strlen(LDict), 1, linear_params->Lin_File.file);
|
||||
|
||||
/* Write document catalog (Part 4) */
|
||||
@@ -2321,8 +2324,11 @@
|
||||
@@ -2346,8 +2349,11 @@
|
||||
if (code != 0)
|
||||
return_error(gs_error_ioerror);
|
||||
|
||||
|
@ -34,10 +34,10 @@ diff -ur orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c gnu-ghostscript-9.
|
|||
+ if (pdev->OwnerPassword.size > 0 || !(!getenv("GS_GENERATE_UUIDS") || (strcasecmp(getenv("GS_GENERATE_UUIDS"), "0") != 0 || strcasecmp(getenv("GS_GENERATE_UUIDS"), "no") != 0))) /* ID is mandatory when encrypting */
|
||||
+ gs_sprintf(LDict, "/ID[%s%s]", fileID, fileID);
|
||||
+ gs_sprintf(LDict, "/Prev %"PRId64">>\nstartxref\r\n0\n%%%%EOF\n", mainxref);
|
||||
fwrite(LDict, strlen(LDict), 1, linear_params->sfile);
|
||||
gp_fwrite(LDict, strlen(LDict), 1, linear_params->sfile);
|
||||
|
||||
code = gp_fseek_64(linear_params->sfile, pdev->ResourceUsage[HintStreamObj].LinearisedOffset, SEEK_SET);
|
||||
@@ -3016,10 +3022,12 @@
|
||||
code = gp_fseek(linear_params->sfile, pdev->ResourceUsage[HintStreamObj].LinearisedOffset, SEEK_SET);
|
||||
@@ -3012,10 +3018,12 @@
|
||||
stream_puts(s, "trailer\n");
|
||||
pprintld3(s, "<< /Size %ld /Root %ld 0 R /Info %ld 0 R\n",
|
||||
pdev->next_id, Catalog_id, Info_id);
|
||||
|
|
Reference in New Issue