gnu: t4k-common: Add missing patch.
* gnu/packages/patches/t4k-common-libpng16.patch: Add file. * gnu/local.mk (dist_patch_DATA): Reference it here.master
parent
227aeeb64c
commit
e1026ba701
|
@ -1412,6 +1412,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/t1lib-CVE-2010-2642.patch \
|
%D%/packages/patches/t1lib-CVE-2010-2642.patch \
|
||||||
%D%/packages/patches/t1lib-CVE-2011-0764.patch \
|
%D%/packages/patches/t1lib-CVE-2011-0764.patch \
|
||||||
%D%/packages/patches/t1lib-CVE-2011-1552+.patch \
|
%D%/packages/patches/t1lib-CVE-2011-1552+.patch \
|
||||||
|
%D%/packages/patches/t4k-common-libpng16.png \
|
||||||
%D%/packages/patches/tar-remove-wholesparse-check.patch \
|
%D%/packages/patches/tar-remove-wholesparse-check.patch \
|
||||||
%D%/packages/patches/tar-skip-unreliable-tests.patch \
|
%D%/packages/patches/tar-skip-unreliable-tests.patch \
|
||||||
%D%/packages/patches/tcc-boot-0.9.27.patch \
|
%D%/packages/patches/tcc-boot-0.9.27.patch \
|
||||||
|
|
|
@ -0,0 +1,26 @@
|
||||||
|
Description: Fix for libpng 1.6
|
||||||
|
Author: Programmer Nerd <theprogrammernerd@gmail.com>
|
||||||
|
Origin: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743388#20
|
||||||
|
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743388
|
||||||
|
Reviewed-by: Tobias Frost <tobi@debian.org>>
|
||||||
|
Last-Update: 2016-04-07
|
||||||
|
---
|
||||||
|
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
||||||
|
--- a/src/t4k_loaders.c
|
||||||
|
+++ b/src/t4k_loaders.c
|
||||||
|
@@ -1028,12 +1028,9 @@
|
||||||
|
{
|
||||||
|
png_init_io(png_ptr, fi);
|
||||||
|
|
||||||
|
- info_ptr->width = surf->w;
|
||||||
|
- info_ptr->height = surf->h;
|
||||||
|
- info_ptr->bit_depth = 8;
|
||||||
|
- info_ptr->color_type = PNG_COLOR_TYPE_RGB_ALPHA;
|
||||||
|
- info_ptr->interlace_type = 1;
|
||||||
|
- info_ptr->valid = 0; /* will be updated by various png_set_FOO() functions */
|
||||||
|
+ png_set_IHDR(png_ptr, info_ptr, surf->w, surf->h, 8,
|
||||||
|
+ PNG_COLOR_TYPE_RGB_ALPHA, PNG_INTERLACE_NONE,
|
||||||
|
+ PNG_COMPRESSION_TYPE_DEFAULT, PNG_FILTER_TYPE_DEFAULT);
|
||||||
|
|
||||||
|
png_set_sRGB_gAMA_and_cHRM(png_ptr, info_ptr,
|
||||||
|
PNG_sRGB_INTENT_PERCEPTUAL);
|
Reference in New Issue