gnu: ark: Update to 24.05.2.
* gnu/packages/kde-utils.scm (ark): Update to 24.05.2. [inputs]: Remove khtml and qtbase-5; add kfilemetadata. [arguments]: Set #:qtbase to qtbase; Use Gexps. * gnu/packages/patches/ark-skip-xar-test.patch: Adjust it. Change-Id: I225a2e0c6487001160cb7d81032b6dcd1fef12ddmaster
parent
1fd0cc75b0
commit
e2c0a0bdd7
|
@ -54,42 +54,44 @@
|
||||||
(define-public ark
|
(define-public ark
|
||||||
(package
|
(package
|
||||||
(name "ark")
|
(name "ark")
|
||||||
(version "23.04.3")
|
(version "24.05.2")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://kde/stable/release-service/" version
|
(uri (string-append "mirror://kde/stable/release-service/" version
|
||||||
"/src/ark-" version ".tar.xz"))
|
"/src/ark-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"081swq9f87yxg4dxdl5i4hszhr0q4ph402in397zfa5vpyspzy41"))
|
"1q0fyx65gp0d1vj4jxiaswdfzi15hbfi537f3i8y277b621qp3rs"))
|
||||||
;; The libarchive package in Guix does not support
|
;; The libarchive package in Guix does not support
|
||||||
;; xar; disable related tests.
|
;; xar; disable related tests.
|
||||||
(patches (search-patches "ark-skip-xar-test.patch"))))
|
(patches (search-patches "ark-skip-xar-test.patch"))))
|
||||||
(build-system qt-build-system)
|
(build-system qt-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases
|
(list
|
||||||
(modify-phases %standard-phases
|
#:qtbase qtbase
|
||||||
(add-before 'check 'start-xserver
|
#:phases
|
||||||
;; adddialogtest requires DISPLAY.
|
#~(modify-phases %standard-phases
|
||||||
(lambda* (#:key inputs #:allow-other-keys)
|
(add-before 'check 'start-xserver
|
||||||
(let ((xorg-server (assoc-ref inputs "xorg-server")))
|
;; adddialogtest requires DISPLAY.
|
||||||
(setenv "HOME" (getcwd))
|
(lambda* (#:key inputs #:allow-other-keys)
|
||||||
(system (format #f "~a/bin/Xvfb :1 &" xorg-server))
|
(let ((xorg-server (assoc-ref inputs "xorg-server")))
|
||||||
(setenv "DISPLAY" ":1"))))
|
(setenv "HOME" (getcwd))
|
||||||
(add-after 'install 'wrap-executable
|
(system (format #f "~a/bin/Xvfb :1 &" xorg-server))
|
||||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
(setenv "DISPLAY" ":1"))))
|
||||||
(let* ((out (assoc-ref outputs "out"))
|
(add-after 'install 'wrap-executable
|
||||||
(lrzip (assoc-ref inputs "lrzip"))
|
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||||
(lzop (assoc-ref inputs "lzop"))
|
(let* ((out (assoc-ref outputs "out"))
|
||||||
(p7zip (assoc-ref inputs "p7zip"))
|
(lrzip (assoc-ref inputs "lrzip"))
|
||||||
(unzip (assoc-ref inputs "unzip"))
|
(lzop (assoc-ref inputs "lzop"))
|
||||||
(zip (assoc-ref inputs "zip"))
|
(p7zip (assoc-ref inputs "p7zip"))
|
||||||
(zstd (assoc-ref inputs "zstd")))
|
(unzip (assoc-ref inputs "unzip"))
|
||||||
(wrap-program (string-append out "/bin/ark")
|
(zip (assoc-ref inputs "zip"))
|
||||||
`("PATH" suffix
|
(zstd (assoc-ref inputs "zstd")))
|
||||||
,(map (lambda (p)
|
(wrap-program (string-append out "/bin/ark")
|
||||||
(string-append p "/bin"))
|
`("PATH" suffix
|
||||||
(list lrzip lzop p7zip unzip zip zstd))))))))))
|
,(map (lambda (p)
|
||||||
|
(string-append p "/bin"))
|
||||||
|
(list lrzip lzop p7zip unzip zip zstd))))))))))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list extra-cmake-modules pkg-config kdoctools xorg-server))
|
(list extra-cmake-modules pkg-config kdoctools xorg-server))
|
||||||
(inputs
|
(inputs
|
||||||
|
@ -99,7 +101,6 @@
|
||||||
kconfig
|
kconfig
|
||||||
kcrash
|
kcrash
|
||||||
kdbusaddons
|
kdbusaddons
|
||||||
khtml
|
|
||||||
ki18n
|
ki18n
|
||||||
kiconthemes
|
kiconthemes
|
||||||
kio
|
kio
|
||||||
|
@ -108,9 +109,9 @@
|
||||||
kpty
|
kpty
|
||||||
kservice
|
kservice
|
||||||
kwidgetsaddons
|
kwidgetsaddons
|
||||||
|
kfilemetadata
|
||||||
libarchive
|
libarchive
|
||||||
libzip
|
libzip
|
||||||
qtbase-5
|
|
||||||
zlib
|
zlib
|
||||||
;; Command line tools used by Ark.
|
;; Command line tools used by Ark.
|
||||||
lrzip
|
lrzip
|
||||||
|
|
|
@ -1,44 +1,36 @@
|
||||||
Guix libarchive no support xar.
|
Guix libarchive no support xar.
|
||||||
|
|
||||||
--- ark-20.04.1.orig/autotests/kerfuffle/loadtest.cpp 2020-12-23 08:46:15.780782601 +0800
|
--- ark-24.05.2.orig/autotests/kerfuffle/loadtest.cpp 2024-07-08 11:19:30.347366493 +0800
|
||||||
+++ ark-20.04.1/autotests/kerfuffle/loadtest.cpp 2020-12-23 11:13:17.101724042 +0800
|
+++ ark-24.05.2/autotests/kerfuffle/loadtest.cpp 2024-07-08 11:19:47.495641516 +0800
|
||||||
@@ -181,13 +181,6 @@
|
@@ -125,8 +125,6 @@
|
||||||
qDebug() << "lz4 executable not found in path. Skipping lz4 test.";
|
qDebug() << "lz4 executable not found in path. Skipping lz4 test.";
|
||||||
}
|
}
|
||||||
|
|
||||||
- QTest::newRow("xar archive")
|
- QTest::newRow("xar archive") << QFINDTESTDATA("data/simplearchive.xar") << QStringLiteral("simplearchive") << true << false << false << false << false << 0
|
||||||
- << QFINDTESTDATA("data/simplearchive.xar")
|
- << Archive::Unencrypted << 6 << QStringLiteral("simplearchive") << QString();
|
||||||
- << QStringLiteral("simplearchive")
|
|
||||||
- << true << false << false << false << false << 0 << Archive::Unencrypted
|
QTest::newRow("mimetype child of application/zip") << QFINDTESTDATA("data/test.odt") << QStringLiteral("test") << false << true << false << false << false
|
||||||
- << QStringLiteral("simplearchive")
|
<< 0 << Archive::Unencrypted << 17 << QStringLiteral("test") << QString();
|
||||||
- << QString();
|
|
||||||
-
|
|
||||||
QTest::newRow("mimetype child of application/zip")
|
--- ark-24.05.2.orig/autotests/kerfuffle/extracttest.cpp 2024-07-08 11:21:25.849219202 +0800
|
||||||
<< QFINDTESTDATA("data/test.odt")
|
+++ ark-24.05.2/autotests/kerfuffle/extracttest.cpp 2024-07-08 11:22:01.413789814 +0800
|
||||||
<< QStringLiteral("test")
|
@@ -329,18 +329,5 @@
|
||||||
--- ark-20.04.1.orig/autotests/kerfuffle/extracttest.cpp 2020-12-23 08:46:15.780782601 +0800
|
|
||||||
+++ ark-20.04.1/autotests/kerfuffle/extracttest.cpp 2020-12-23 11:14:02.801809620 +0800
|
|
||||||
@@ -350,23 +350,6 @@
|
|
||||||
qDebug() << "lz4 executable not found in path. Skipping lz4 test.";
|
qDebug() << "lz4 executable not found in path. Skipping lz4 test.";
|
||||||
}
|
}
|
||||||
|
|
||||||
- archivePath = QFINDTESTDATA("data/simplearchive.xar");
|
- archivePath = QFINDTESTDATA("data/simplearchive.xar");
|
||||||
- QTest::newRow("extract selected entries from a xar archive without path")
|
- setupRow("extract selected entries from a xar archive without path",
|
||||||
- << archivePath
|
- archivePath,
|
||||||
- << QVector<Archive::Entry*> {
|
- QList<Archive::Entry *>{
|
||||||
- new Archive::Entry(this, QStringLiteral("dir1/file11.txt"), QString()),
|
- new Archive::Entry(this, QStringLiteral("dir1/file11.txt"), QString()),
|
||||||
- new Archive::Entry(this, QStringLiteral("file4.txt"), QString())
|
- new Archive::Entry(this, QStringLiteral("file4.txt"), QString()),
|
||||||
- }
|
- },
|
||||||
- << optionsNoPaths
|
- optionsNoPaths,
|
||||||
- << 2;
|
- 2);
|
||||||
-
|
-
|
||||||
- archivePath = QFINDTESTDATA("data/simplearchive.xar");
|
- archivePath = QFINDTESTDATA("data/simplearchive.xar");
|
||||||
- QTest::newRow("extract all entries from a xar archive with path")
|
- setupRow("extract all entries from a xar archive with path", archivePath, QList<Archive::Entry *>(), optionsPreservePaths, 6);
|
||||||
- << archivePath
|
|
||||||
- << QVector<Archive::Entry*>()
|
|
||||||
- << optionsPreservePaths
|
|
||||||
- << 6;
|
|
||||||
-
|
-
|
||||||
archivePath = QFINDTESTDATA("data/hello-1.0-x86_64.AppImage");
|
archivePath = QFINDTESTDATA("data/hello-1.0-x86_64.AppImage");
|
||||||
QTest::newRow("extract all entries from an AppImage with path")
|
setupRow("extract all entries from an AppImage with path", archivePath, QList<Archive::Entry *>(), optionsPreservePaths, 7);
|
||||||
<< archivePath
|
|
||||||
|
|
Reference in New Issue