gnu: rust-cargo-edit: Update to 0.12.2.
* gnu/packages/rust-apps.scm (rust-cargo-edit): Update to 0.12.2. [source]: Add patch. [cargo-inputs]: Add rust-clap-cargo-0.12, rust-home-0.5, rust-toml-0.7. Replace rust-clap-3 with 4, rust-crates-index-0.18 with 0.19, rust-git2-0.14 with 0.17, rust-toml-edit-0.14 with 0.19. Remove rust-dirs-next-2, rust-ureq-2. [cargo-development-inputs]: Replace rust-predicates-2 with 3, rust-snapbox-0.2 with 0.4, rust-trycmd-0.13 with 0.14. [inputs]: Replace libgit2-1.4 with 1.6. * gnu/packages/patches/rust-cargo-edit-remove-ureq.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I71ac74de44e322eb9f5233262b3a989395b592ffmaster
parent
e6fdadbe8f
commit
e2cf93aaa8
|
@ -2001,6 +2001,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/rustc-1.54.0-src.patch \
|
%D%/packages/patches/rustc-1.54.0-src.patch \
|
||||||
%D%/packages/patches/rust-1.64-fix-riscv64-bootstrap.patch \
|
%D%/packages/patches/rust-1.64-fix-riscv64-bootstrap.patch \
|
||||||
%D%/packages/patches/rust-1.70-fix-rustix-build.patch \
|
%D%/packages/patches/rust-1.70-fix-rustix-build.patch \
|
||||||
|
%D%/packages/patches/rust-cargo-edit-remove-ureq.patch \
|
||||||
%D%/packages/patches/rust-ring-0.17-ring-core.patch \
|
%D%/packages/patches/rust-ring-0.17-ring-core.patch \
|
||||||
%D%/packages/patches/i3status-rust-enable-unstable-features.patch \
|
%D%/packages/patches/i3status-rust-enable-unstable-features.patch \
|
||||||
%D%/packages/patches/rust-ndarray-remove-blas-src-dep.patch \
|
%D%/packages/patches/rust-ndarray-remove-blas-src-dep.patch \
|
||||||
|
|
|
@ -0,0 +1,33 @@
|
||||||
|
This is modeled after the upstream commit which removes ureq as a dependency.
|
||||||
|
|
||||||
|
diff --git a/Cargo.toml b/Cargo.toml
|
||||||
|
index 5a787e1..27171c7 100644
|
||||||
|
--- a/Cargo.toml
|
||||||
|
+++ b/Cargo.toml
|
||||||
|
@@ -201,26 +201,3 @@ test-external-apis = []
|
||||||
|
upgrade = ["cli"]
|
||||||
|
vendored-libgit2 = ["git2/vendored-libgit2"]
|
||||||
|
vendored-openssl = ["git2/vendored-openssl"]
|
||||||
|
-
|
||||||
|
-[target."cfg(any(target_arch = \"x86_64\", target_arch = \"arm\", target_arch = \"x86\", target_arch = \"aarch64\"))".dependencies.ureq]
|
||||||
|
-version = "2.7.1"
|
||||||
|
-features = [
|
||||||
|
- "tls",
|
||||||
|
- "json",
|
||||||
|
- "socks",
|
||||||
|
- "socks-proxy",
|
||||||
|
-]
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
-[target."cfg(not(any(target_arch = \"x86_64\", target_arch = \"arm\", target_arch = \"x86\", target_arch = \"aarch64\")))".dependencies.native-tls]
|
||||||
|
-version = "^0.2"
|
||||||
|
-
|
||||||
|
-[target."cfg(not(any(target_arch = \"x86_64\", target_arch = \"arm\", target_arch = \"x86\", target_arch = \"aarch64\")))".dependencies.ureq]
|
||||||
|
-version = "2.7.1"
|
||||||
|
-features = [
|
||||||
|
- "native-tls",
|
||||||
|
- "json",
|
||||||
|
- "socks",
|
||||||
|
- "socks-proxy",
|
||||||
|
-]
|
||||||
|
-default-features = false
|
|
@ -1450,14 +1450,15 @@ browsers.")
|
||||||
(define-public rust-cargo-edit
|
(define-public rust-cargo-edit
|
||||||
(package
|
(package
|
||||||
(name "rust-cargo-edit")
|
(name "rust-cargo-edit")
|
||||||
(version "0.10.4")
|
(version "0.12.2")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (crate-uri "cargo-edit" version))
|
(uri (crate-uri "cargo-edit" version))
|
||||||
(file-name (string-append name "-" version ".tar.gz"))
|
(file-name (string-append name "-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"19wfjz7z4kqjfjmnq1bl6dhsvskjy6r656fqmbha9dfdspbsnmd0"))))
|
"03lxi7z1n9xq287lqvqnhzg5r0yv1fi3569ryw3jqcrvv8nqs0c2"))
|
||||||
|
(patches (search-patches "rust-cargo-edit-remove-ureq.patch"))))
|
||||||
(build-system cargo-build-system)
|
(build-system cargo-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:install-source? #f
|
`(#:install-source? #f
|
||||||
|
@ -1466,14 +1467,15 @@ browsers.")
|
||||||
#:cargo-inputs
|
#:cargo-inputs
|
||||||
(("rust-anyhow" ,rust-anyhow-1)
|
(("rust-anyhow" ,rust-anyhow-1)
|
||||||
("rust-cargo-metadata" ,rust-cargo-metadata-0.15)
|
("rust-cargo-metadata" ,rust-cargo-metadata-0.15)
|
||||||
("rust-clap" ,rust-clap-3)
|
("rust-clap" ,rust-clap-4)
|
||||||
|
("rust-clap-cargo" ,rust-clap-cargo-0.12)
|
||||||
("rust-concolor-control" ,rust-concolor-control-0.0.7)
|
("rust-concolor-control" ,rust-concolor-control-0.0.7)
|
||||||
("rust-crates-index" ,rust-crates-index-0.18)
|
("rust-crates-index" ,rust-crates-index-0.19)
|
||||||
("rust-dirs-next" ,rust-dirs-next-2)
|
|
||||||
("rust-dunce" ,rust-dunce-1)
|
("rust-dunce" ,rust-dunce-1)
|
||||||
("rust-env-proxy" ,rust-env-proxy-0.4)
|
("rust-env-proxy" ,rust-env-proxy-0.4)
|
||||||
("rust-git2" ,rust-git2-0.14)
|
("rust-git2" ,rust-git2-0.17)
|
||||||
("rust-hex" ,rust-hex-0.4)
|
("rust-hex" ,rust-hex-0.4)
|
||||||
|
("rust-home" ,rust-home-0.5)
|
||||||
("rust-indexmap" ,rust-indexmap-1)
|
("rust-indexmap" ,rust-indexmap-1)
|
||||||
("rust-native-tls" ,rust-native-tls-0.2)
|
("rust-native-tls" ,rust-native-tls-0.2)
|
||||||
("rust-pathdiff" ,rust-pathdiff-0.2)
|
("rust-pathdiff" ,rust-pathdiff-0.2)
|
||||||
|
@ -1484,15 +1486,15 @@ browsers.")
|
||||||
("rust-serde-json" ,rust-serde-json-1)
|
("rust-serde-json" ,rust-serde-json-1)
|
||||||
("rust-subprocess" ,rust-subprocess-0.2)
|
("rust-subprocess" ,rust-subprocess-0.2)
|
||||||
("rust-termcolor" ,rust-termcolor-1)
|
("rust-termcolor" ,rust-termcolor-1)
|
||||||
("rust-toml-edit" ,rust-toml-edit-0.14)
|
("rust-toml" ,rust-toml-0.7)
|
||||||
("rust-ureq" ,rust-ureq-2)
|
("rust-toml-edit" ,rust-toml-edit-0.19)
|
||||||
("rust-url" ,rust-url-2))
|
("rust-url" ,rust-url-2))
|
||||||
#:cargo-development-inputs
|
#:cargo-development-inputs
|
||||||
(("rust-assert-cmd" ,rust-assert-cmd-2)
|
(("rust-assert-cmd" ,rust-assert-cmd-2)
|
||||||
("rust-assert-fs" ,rust-assert-fs-1)
|
("rust-assert-fs" ,rust-assert-fs-1)
|
||||||
("rust-predicates" ,rust-predicates-2)
|
("rust-predicates" ,rust-predicates-3)
|
||||||
("rust-snapbox" ,rust-snapbox-0.2)
|
("rust-snapbox" ,rust-snapbox-0.4)
|
||||||
("rust-trycmd" ,rust-trycmd-0.13)
|
("rust-trycmd" ,rust-trycmd-0.14)
|
||||||
("rust-url" ,rust-url-2))
|
("rust-url" ,rust-url-2))
|
||||||
#:phases
|
#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
|
@ -1503,7 +1505,7 @@ browsers.")
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list pkg-config))
|
(list pkg-config))
|
||||||
(inputs
|
(inputs
|
||||||
(list libgit2-1.4
|
(list libgit2-1.6
|
||||||
libssh2
|
libssh2
|
||||||
openssl
|
openssl
|
||||||
zlib))
|
zlib))
|
||||||
|
|
Reference in New Issue