gnu: gdb: Add version 10.1.
* gnu/packages/gdb.scm (gdb-9.2): Rename to... (gdb-10): ... this, and upgrade to 10.1. [inputs]: New field. (gdb-minimal): Adjust accordingly. * gnu/packages/patches/gdb-hurd.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it.
parent
a8c1eabaf1
commit
e33c4286eb
|
@ -1024,7 +1024,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gcc-9-strmov-store-file-names.patch \
|
||||
%D%/packages/patches/gd-fix-tests-on-i686.patch \
|
||||
%D%/packages/patches/gd-brect-bounds.patch \
|
||||
%D%/packages/patches/gdb-hurd.patch \
|
||||
%D%/packages/patches/gdm-default-session.patch \
|
||||
%D%/packages/patches/genimage-signedness.patch \
|
||||
%D%/packages/patches/geoclue-config.patch \
|
||||
|
|
|
@ -152,22 +152,24 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
|
|||
;; enough to avoid massive rebuilds.
|
||||
gdb-9.1)
|
||||
|
||||
(define-public gdb-9.2
|
||||
(define-public gdb-10
|
||||
(package
|
||||
(inherit gdb)
|
||||
(version "9.2")
|
||||
(version "10.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/gdb/gdb-"
|
||||
version ".tar.xz"))
|
||||
(patches (search-patches "gdb-hurd.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0mf5fn8v937qwnal4ykn3ji1y2sxk0fa1yfqi679hxmpg6pdf31n"))))))
|
||||
"1h32dckz1y8fnyxh22iyw8h3hnhxr79v1ng85px3ljn1xv71wbzq"))))
|
||||
(inputs
|
||||
`(("guile" ,guile-3.0)
|
||||
,@(alist-delete "guile" (package-inputs gdb))))))
|
||||
|
||||
(define-public gdb-minimal
|
||||
(package/inherit
|
||||
gdb-9.2
|
||||
gdb-10
|
||||
(name "gdb-minimal")
|
||||
(inputs (fold alist-delete (package-inputs gdb)
|
||||
'("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
|
||||
|
|
|
@ -1,69 +0,0 @@
|
|||
Taken from upstream, removed ChangeLog.
|
||||
|
||||
From 6930bffe3373690b3431d6291f9f7c116d6a1ec4 Mon Sep 17 00:00:00 2001
|
||||
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
|
||||
Date: Sat, 30 May 2020 18:35:59 +0000
|
||||
Subject: [PATCH] hurd: fix gnu_debug_flag type
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Fixes
|
||||
|
||||
../../gdb/gnu-nat.c:96:6: error: conflicting declaration ‘bool gnu_debug_flag’
|
||||
96 | bool gnu_debug_flag = false;
|
||||
../../gdb/gnu-nat.c: In function ‘void _initialize_gnu_nat()’:
|
||||
../../gdb/gnu-nat.c:3511:7: error: cannot
|
||||
|
||||
gdb/ChangeLog:
|
||||
|
||||
* gnu-nat.h (gnu_debug_flag): Set type to bool.
|
||||
---
|
||||
gdb/ChangeLog | 4 ++++
|
||||
gdb/gnu-nat.h | 2 +-
|
||||
2 files changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gdb/gnu-nat.h b/gdb/gnu-nat.h
|
||||
index 77c57817b2..766f716587 100644
|
||||
--- a/gdb/gnu-nat.h
|
||||
+++ b/gdb/gnu-nat.h
|
||||
@@ -111,7 +111,7 @@ extern char *proc_string (struct proc *proc);
|
||||
__proc_pid (__proc), __proc->tid, \
|
||||
host_address_to_string (__proc) , ##args); } while (0)
|
||||
|
||||
-extern int gnu_debug_flag;
|
||||
+extern bool gnu_debug_flag;
|
||||
|
||||
#define debug(msg, args...) \
|
||||
do { if (gnu_debug_flag) \
|
||||
--
|
||||
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
|
||||
Freelance IT http://JoyofSource.com | Avatar® http://AvatarAcademy.com
|
||||
|
||||
commit 366f550a593c7e6bae3699a4b6d65fe937af5603
|
||||
Author: Samuel Thibault <samuel.thibault@ens-lyon.org>
|
||||
Date: Sat May 30 18:41:30 2020 +0000
|
||||
|
||||
hurd: add missing include
|
||||
|
||||
Fixes
|
||||
|
||||
../../gdb/gnu-nat.c:2522:14: error: ‘target_gdbarch’ was not declared in this scope; did you mean ‘target_detach’?
|
||||
2522 | paddress (target_gdbarch (), memaddr), pulongest (len),
|
||||
|
||||
gdb/Changelog:
|
||||
|
||||
* gnu-nat.c: Include "gdbarch.h".
|
||||
|
||||
diff --git a/gdb/gnu-nat.c b/gdb/gnu-nat.c
|
||||
index 3b438a9a43..9b93488b41 100644
|
||||
--- a/gdb/gnu-nat.c
|
||||
+++ b/gdb/gnu-nat.c
|
||||
@@ -64,6 +64,7 @@ extern "C"
|
||||
#include "language.h"
|
||||
#include "target.h"
|
||||
#include "gdbsupport/gdb_wait.h"
|
||||
+#include "gdbarch.h"
|
||||
#include "gdbcmd.h"
|
||||
#include "gdbcore.h"
|
||||
#include "gdbthread.h"
|
Reference in New Issue