me
/
guix
Archived
1
0
Fork 0

gnu: QtWebKit: Fix building with glib 2.68.

* gnu/packages/patches/qtwebkit-fix-building-with-glib-2.68.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/qt.scm (qtwebkit)[source]: Use it.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
master
Leo Famulari 2021-08-11 00:23:02 -04:00 committed by Guillaume Le Vaillant
parent fc137ffe09
commit e3b037392a
No known key found for this signature in database
GPG Key ID: 6BE8208ADF21FE3F
3 changed files with 23 additions and 0 deletions

View File

@ -1659,6 +1659,7 @@ dist_patch_DATA = \
%D%/packages/patches/qtwebkit-pbutils-include.patch \
%D%/packages/patches/qtwebkit-fix-building-with-python-3.9.patch \
%D%/packages/patches/qtwebkit-fix-building-with-icu-68.patch \
%D%/packages/patches/qtwebkit-fix-building-with-glib-2.68.patch \
%D%/packages/patches/randomjungle-disable-static-build.patch \
%D%/packages/patches/rapicorn-isnan.patch \
%D%/packages/patches/rapidjson-gcc-compat.patch \

View File

@ -0,0 +1,21 @@
Fix building with glib 2.68:
https://github.com/qtwebkit/qtwebkit/issues/1057
Patch copied from upstream pull request:
https://github.com/qtwebkit/qtwebkit/pull/1058/commits/5b698ba3faffd4e198a45be9fe74f53307395e4b
diff -aurN qtwebkit-5.212.0-alpha4/Source/WTF/wtf/glib/GRefPtr.h qtwebkit-5.212.0-alpha4-mod/Source/WTF/wtf/glib/GRefPtr.h
--- qtwebkit-5.212.0-alpha4/Source/WTF/wtf/glib/GRefPtr.h 2020-03-04 18:16:37.000000000 +0100
+++ qtwebkit-5.212.0-alpha4-mod/Source/WTF/wtf/glib/GRefPtr.h 2021-04-05 06:58:44.763328636 +0200
@@ -29,9 +29,6 @@
#include <wtf/RefPtr.h>
#include <algorithm>
-extern "C" void g_object_unref(gpointer);
-extern "C" gpointer g_object_ref_sink(gpointer);
-
namespace WTF {
enum GRefPtrAdoptType { GRefPtrAdopt };

View File

@ -2625,6 +2625,7 @@ different kinds of sliders, and much more.")
(base32
"1rm9sjkabxna67dl7myx9d9vpdyfxfdhrk9w7b94srkkjbd2d8cw"))
(patches (search-patches "qtwebkit-pbutils-include.patch"
"qtwebkit-fix-building-with-glib-2.68.patch"
"qtwebkit-fix-building-with-icu-68.patch"
"qtwebkit-fix-building-with-python-3.9.patch"))))
(build-system cmake-build-system)