gnu: Add go-1.16.
Add go@1.16 as a non-default go. Changes from 1.14: Use now-supported GO_LDSO configuration option for setting the interpreter. Bootstrap with gccgo on platforms which do not support go-1.4. Fix and re-enable cmd/go script tests. Fix typo in cgoldflags patch. Break out tests into "check" phase. Remove references to perl to reduce closure size by ~10%. Set GOCACHE so go doesn't attempt to access $HOME. * gnu/packages/patches/go-fix-script-tests.patch: New file. * local.mk (dist_patch_DATA): Register it. * gnu/packages/golang.scm (go-1.16): New variable. Use the patch. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>master
parent
ef590de692
commit
e3e4cbb93f
|
@ -1169,6 +1169,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gobject-introspection-absolute-shlib-path.patch \
|
||||
%D%/packages/patches/gobject-introspection-cc.patch \
|
||||
%D%/packages/patches/gobject-introspection-girepository.patch \
|
||||
%D%/packages/patches/go-fix-script-tests.patch \
|
||||
%D%/packages/patches/go-skip-gc-test.patch \
|
||||
%D%/packages/patches/gpm-glibc-2.26.patch \
|
||||
%D%/packages/patches/gpodder-disable-updater.patch \
|
||||
|
|
|
@ -26,6 +26,7 @@
|
|||
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
|
||||
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
|
||||
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@mgail.com>
|
||||
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -45,6 +46,7 @@
|
|||
(define-module (gnu packages golang)
|
||||
#:use-module ((guix licenses) #:prefix license:)
|
||||
#:use-module (guix utils)
|
||||
#:use-module ((guix build utils) #:select (alist-replace))
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix git-download)
|
||||
#:use-module (guix packages)
|
||||
|
@ -54,6 +56,7 @@
|
|||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages admin)
|
||||
#:use-module (gnu packages base)
|
||||
#:use-module ((gnu packages bootstrap) #:select (glibc-dynamic-linker))
|
||||
#:use-module (gnu packages gcc)
|
||||
#:use-module (gnu packages glib)
|
||||
#:use-module (gnu packages lua)
|
||||
|
@ -441,6 +444,162 @@ in the style of communicating sequential processes (@dfn{CSP}).")
|
|||
,@(package-native-inputs go-1.4)))
|
||||
(supported-systems %supported-systems)))
|
||||
|
||||
(define-public go-1.16
|
||||
(package
|
||||
(inherit go-1.14)
|
||||
(name "go")
|
||||
(version "1.16.5")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/golang/go")
|
||||
(commit (string-append "go" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"19a93p217h5xi2sgh34qzv24pkd4df0sw4fc5z6k47lspjp3vx2l"))))
|
||||
(arguments
|
||||
(substitute-keyword-arguments (package-arguments go-1.14)
|
||||
((#:tests? _) #t)
|
||||
((#:phases phases)
|
||||
`(modify-phases ,phases
|
||||
(add-after 'unpack 'remove-unused-sourcecode-generators
|
||||
(lambda _
|
||||
;; Prevent perl from inclusion in closure through unused files
|
||||
(for-each delete-file (find-files "src" "\\.pl$"))))
|
||||
(replace 'prebuild
|
||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||
(let* ((gcclib (string-append (assoc-ref inputs "gcc:lib") "/lib"))
|
||||
(net-base (assoc-ref inputs "net-base"))
|
||||
(tzdata-path
|
||||
(string-append (assoc-ref inputs "tzdata") "/share/zoneinfo")))
|
||||
|
||||
;; Having the patch in the 'patches' field of <origin> breaks
|
||||
;; the 'TestServeContent' test due to the fact that
|
||||
;; timestamps are reset. Thus, apply it from here.
|
||||
(invoke "patch" "-p2" "--force" "-i"
|
||||
(assoc-ref inputs "go-skip-gc-test.patch"))
|
||||
(invoke "patch" "-p2" "--force" "-i"
|
||||
(assoc-ref inputs "go-fix-script-tests.patch"))
|
||||
|
||||
(for-each make-file-writable (find-files "."))
|
||||
|
||||
(substitute* "os/os_test.go"
|
||||
(("/usr/bin") (getcwd))
|
||||
(("/bin/sh") (which "sh")))
|
||||
|
||||
(substitute* "cmd/go/testdata/script/cgo_path_space.txt"
|
||||
(("/bin/sh") (which "sh")))
|
||||
|
||||
;; Add libgcc to runpath
|
||||
(substitute* "cmd/link/internal/ld/lib.go"
|
||||
(("!rpath.set") "true"))
|
||||
(substitute* "cmd/go/internal/work/gccgo.go"
|
||||
(("cgoldflags := \\[\\]string\\{\\}")
|
||||
(string-append "cgoldflags := []string{"
|
||||
"\"-Wl,-rpath=" gcclib "\""
|
||||
"}"))
|
||||
(("\"-lgcc_s\", ")
|
||||
(string-append
|
||||
"\"-Wl,-rpath=" gcclib "\", \"-lgcc_s\", ")))
|
||||
(substitute* "cmd/go/internal/work/gc.go"
|
||||
(("ldflags = setextld\\(ldflags, compiler\\)")
|
||||
(string-append
|
||||
"ldflags = setextld(ldflags, compiler)\n"
|
||||
"ldflags = append(ldflags, \"-r\")\n"
|
||||
"ldflags = append(ldflags, \"" gcclib "\")\n")))
|
||||
|
||||
;; Disable failing tests: these tests attempt to access
|
||||
;; commands or network resources which are neither available
|
||||
;; nor necessary for the build to succeed.
|
||||
(for-each
|
||||
(match-lambda
|
||||
((file regex)
|
||||
(substitute* file
|
||||
((regex all before test_name)
|
||||
(string-append before "Disabled" test_name)))))
|
||||
'(("net/net_test.go" "(.+)(TestShutdownUnix.+)")
|
||||
("net/dial_test.go" "(.+)(TestDialTimeout.+)")
|
||||
("net/cgo_unix_test.go" "(.+)(TestCgoLookupPort.+)")
|
||||
("net/cgo_unix_test.go" "(.+)(TestCgoLookupPortWithCancel.+)")
|
||||
;; 127.0.0.1 doesn't exist
|
||||
("net/cgo_unix_test.go" "(.+)(TestCgoLookupPTR.+)")
|
||||
;; 127.0.0.1 doesn't exist
|
||||
("net/cgo_unix_test.go" "(.+)(TestCgoLookupPTRWithCancel.+)")
|
||||
;; /etc/services doesn't exist
|
||||
("net/parse_test.go" "(.+)(TestReadLine.+)")
|
||||
("os/os_test.go" "(.+)(TestHostname.+)")
|
||||
;; The user's directory doesn't exist
|
||||
("os/os_test.go" "(.+)(TestUserHomeDir.+)")
|
||||
("time/format_test.go" "(.+)(TestParseInSydney.+)")
|
||||
("time/format_test.go" "(.+)(TestParseInLocation.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestEcho.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestCommandRelativeName.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestCatStdin.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestCatGoodAndBadFile.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestExitStatus.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestPipes.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestStdinClose.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestIgnorePipeErrorOnSuccess.+)")
|
||||
("syscall/syscall_unix_test.go" "(.+)(TestPassFD\\(.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestExtraFiles/areturn.+)")
|
||||
("cmd/go/go_test.go" "(.+)(TestCoverageWithCgo.+)")
|
||||
("cmd/go/go_test.go" "(.+)(TestTwoPkgConfigs.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestOutputStderrCapture.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestExtraFiles.+)")
|
||||
("os/exec/exec_test.go" "(.+)(TestExtraFilesRace.+)")
|
||||
("net/lookup_test.go" "(.+)(TestLookupPort.+)")
|
||||
("syscall/exec_linux_test.go"
|
||||
"(.+)(TestCloneNEWUSERAndRemapNoRootDisableSetgroups.+)")))
|
||||
|
||||
;; These tests fail on aarch64-linux
|
||||
(substitute* "cmd/dist/test.go"
|
||||
(("t.registerHostTest\\(\"testsanitizers/msan.*") ""))
|
||||
|
||||
;; fix shebang for testar script
|
||||
;; note the target script is generated at build time.
|
||||
(substitute* "../misc/cgo/testcarchive/carchive_test.go"
|
||||
(("#!/usr/bin/env") (string-append "#!" (which "env"))))
|
||||
|
||||
(substitute* "net/lookup_unix.go"
|
||||
(("/etc/protocols") (string-append net-base "/etc/protocols")))
|
||||
(substitute* "net/port_unix.go"
|
||||
(("/etc/services") (string-append net-base "/etc/services")))
|
||||
(substitute* "time/zoneinfo_unix.go"
|
||||
(("/usr/share/zoneinfo/") tzdata-path)))))
|
||||
(replace 'build
|
||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||
;; FIXME: Some of the .a files are not bit-reproducible.
|
||||
;; (Is this still true?)
|
||||
(let* ((output (assoc-ref outputs "out"))
|
||||
(loader (string-append (assoc-ref inputs "libc")
|
||||
,(glibc-dynamic-linker))))
|
||||
(setenv "CC" (which "gcc"))
|
||||
(setenv "GO_LDSO" loader)
|
||||
(setenv "GOOS" "linux")
|
||||
(setenv "GOROOT" (dirname (getcwd)))
|
||||
(setenv "GOROOT_FINAL" output)
|
||||
(setenv "GOCACHE" "/tmp/go-cache")
|
||||
(invoke "sh" "make.bash" "--no-banner"))))
|
||||
(replace 'check
|
||||
(lambda* (#:key target (tests? (not target)) (parallel-tests? #t)
|
||||
#:allow-other-keys)
|
||||
(let* ((njobs (if parallel-tests? (parallel-job-count) 1)))
|
||||
(when tests?
|
||||
(setenv "GOMAXPROCS" (number->string njobs))
|
||||
(invoke "sh" "run.bash" "--no-rebuild")))))
|
||||
(add-before 'install 'unpatch-perl-shebangs
|
||||
(lambda _
|
||||
;; Rewrite references to perl input in test scripts
|
||||
(substitute* "net/http/cgi/testdata/test.cgi"
|
||||
(("^#!.*") "#!/usr/bin/env perl\n"))))))))
|
||||
(native-inputs
|
||||
`(("go-fix-script-tests.patch" ,(search-patch "go-fix-script-tests.patch"))
|
||||
,@(if (not (member (%current-system) (package-supported-systems go-1.4)))
|
||||
(alist-replace "go" (list gccgo-10) (package-native-inputs go-1.14))
|
||||
(package-native-inputs go-1.14))))))
|
||||
|
||||
(define-public go go-1.14)
|
||||
|
||||
(define-public go-github-com-alsm-ioprogress
|
||||
|
|
|
@ -0,0 +1,18 @@
|
|||
Make library/header paths visible to cmd/go script tests, which is necessary for
|
||||
cgo/gccgo tests to work correctly
|
||||
|
||||
diff --git a/src/cmd/go/script_test.go b/src/cmd/go/script_test.go
|
||||
index dfaa40548e..9d0f0e9bcd 100644
|
||||
--- a/src/cmd/go/script_test.go
|
||||
+++ b/src/cmd/go/script_test.go
|
||||
@@ -100,6 +100,10 @@ const (
|
||||
var extraEnvKeys = []string{
|
||||
"SYSTEMROOT", // must be preserved on Windows to find DLLs; golang.org/issue/25210
|
||||
"WINDIR", // must be preserved on Windows to be able to run PowerShell command; golang.org/issue/30711
|
||||
+ "CPATH",
|
||||
+ "C_INCLUDE_PATH",
|
||||
+ "CPLUS_INCLUDE_PATH",
|
||||
+ "LIBRARY_PATH",
|
||||
"LD_LIBRARY_PATH", // must be preserved on Unix systems to find shared libraries
|
||||
"CC", // don't lose user settings when invoking cgo
|
||||
"GO_TESTING_GOTOOLS", // for gccgo testing
|
Reference in New Issue