me
/
guix
Archived
1
0
Fork 0

gnu: emacs-buttercup: Fix native comp tests with emacs-next.

* gnu/packages/emacs-xyz.scm (emacs-buttercup): Add patch emacs-buttercup-fix-native-comp-pretty-test.
* gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch: Add
file.
* gnu/local.mk: Add emacs-buttercup-fix-native-comp-pretty-test.patch.

Signed-off-by: Andrew Tropin <andrew@trop.in>
Nicolas Graves 2023-10-01 22:12:15 +02:00 committed by Andrew Tropin
parent 3b71b2dca7
commit e45f9b4b12
No known key found for this signature in database
GPG Key ID: 2208D20958C1DEB0
3 changed files with 36 additions and 1 deletions

View File

@ -1095,6 +1095,7 @@ dist_patch_DATA = \
%D%/packages/patches/elm-reactor-static-files.patch \
%D%/packages/patches/elogind-fix-rpath.patch \
%D%/packages/patches/emacs-all-the-icons-remove-duplicate-rs.patch \
%D%/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch \
%D%/packages/patches/emacs-deferred-fix-number-of-arguments.patch \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-ess-fix-obsolete-function-alias.patch \

View File

@ -28521,7 +28521,9 @@ targets the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.)")
(file-name (git-file-name name version))
(sha256
(base32
"1rvc9r6swb74lhzd877jidkkf2cxl5v4zz302j2imqhsbk844qzh"))))
"1rvc9r6swb74lhzd877jidkkf2cxl5v4zz302j2imqhsbk844qzh"))
(patches
(search-patches "emacs-buttercup-fix-native-comp-pretty-test.patch"))))
(build-system emacs-build-system)
(arguments
(list

View File

@ -0,0 +1,32 @@
From 0f822190360a99bac6b532058beb5e20cb2673c3 Mon Sep 17 00:00:00 2001
From: Nicolas Graves <ngraves@ngraves.fr>
Date: Sun, 1 Oct 2023 20:20:03 +0200
Subject: [PATCH] test: Change `pretty' test regexp to pass tests on emacs 30.
---
tests/test-buttercup.el | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)
diff --git a/tests/test-buttercup.el b/tests/test-buttercup.el
index d68787b..a2e3ba7 100644
--- a/tests/test-buttercup.el
+++ b/tests/test-buttercup.el
@@ -2009,9 +2009,15 @@ text properties using `ansi-color-apply'."
"suite bc-bt-backtrace\n"
"\n"
"Traceback (most recent call last):\n"
- "λ (bc-bt-foo \"" (regex ,long-string) "\")\n"
- "λ (bc-bt-bar \"" (regex ,long-string) "\")\n"
- "λ (bc-bt-baz \"" (regex ,long-string) "\")\n"
+ (seq
+ "λ (bc-bt-foo \"" (regex ,long-string) "\")"
+ (optional "\n"))
+ (seq
+ "λ (bc-bt-bar \"" (regex ,long-string) "\")"
+ (optional "\n"))
+ (seq
+ "λ (bc-bt-baz \"" (regex ,long-string) "\")"
+ (optional "\n"))
(* (seq (or ?M ?λ) " (" (* not-newline) ; frame start
(*? (seq "\n " (* not-newline))) ; any number of pp lines
(* not-newline) ")\n")) ;; frame end