From e5cd7028d71cea924c2884ed50453f463e19fe43 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Wed, 12 Jul 2023 22:14:43 +0200
Subject: [PATCH] gnu: Add texlive-curve2e.

* gnu/packages/tex.scm (texlive-curve2e): New variable.
---
 gnu/packages/tex.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1e22fe34e6..5b98d3e167 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16669,6 +16669,29 @@ order to emphasize on different aspects of your background.  CurVe also comes
 with support for use with AUC-TeX.")
     (license license:lppl)))
 
+(define-public texlive-curve2e
+  (package
+    (name "texlive-curve2e")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/curve2e/" "source/latex/curve2e/"
+                   "tex/latex/curve2e/")
+             (base32
+              "0fa2xp3yh1bv8ivxf48ywiwi9wjgq0bnvnyc2rcy73wczwilsyk4")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/curve2e")
+    (synopsis "Extensions for package @code{pict2e}")
+    (description
+     "The package extends the drawing capacities of the @code{pict2e} package
+that serves as a LaTeX2e replacement for @code{picture} mode.  In particular,
+@code{curve2e} introduces new macros for lines and vectors, new specifications
+for line terminations and joins, arcs with any angular aperture, arcs with
+arrows at one or both ends, generic curves specified with their nodes and the
+tangent direction at these nodes.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-gates
   (package
     (name "texlive-gates")