Revert "gnu: Fix Krita."
This reverts commit 5f63905096
.
This commit caused `guix pull` to crash like this:
------
Backtrace:
In ice-9/boot-9.scm:
222:29 19 (map1 _)
222:29 18 (map1 _)
222:29 17 (map1 _)
222:29 16 (map1 _)
222:17 15 (map1 (((gnu packages kde)) ((gnu packages libevent)) ((gnu packages libidn)) ((gnu packages #)) ((?)) ?))
3297:17 14 (resolve-interface (gnu packages kde) #:select _ #:hide _ #:prefix _ #:renamer _ #:version _)
In ice-9/threads.scm:
390:8 13 (_ _)
In ice-9/boot-9.scm:
3223:13 12 (_)
In ice-9/threads.scm:
390:8 11 (_ _)
In ice-9/boot-9.scm:
3507:20 10 (_)
2806:4 9 (save-module-excursion _)
3527:26 8 (_)
In unknown file:
7 (primitive-load-path "gnu/packages/kde" #<procedure 7f68d6fe5da0 at ice-9/boot-9.scm:3514:37 ()>)
In ice-9/eval.scm:
626:19 6 (_ #<directory (gnu packages kde) 7f68d6175b40>)
293:34 5 (_ #<directory (gnu packages kde) 7f68d6175b40>)
173:47 4 (_ #(#<directory (gnu packages kde) 7f68d6175b40> #<promise #<procedure 7f68dc5a5d00 at ice-9/eval.sc?>))
159:9 3 (_ #(#<directory (gnu packages kde) 7f68d6175b40> #<promise #<procedure 7f68dc5a5d00 at ice-9/eval.sc?>))
191:35 2 (_ #(#<directory (gnu packages kde) 7f68d6175b40> #<promise #<procedure 7f68dc5a5d00 at ice-9/eval.sc?>))
223:20 1 (proc #(#<directory (gnu packages kde) 7f68d6175b40> #<promise #<procedure 7f68dc5a5d00 at ice-9/eval?>))
In unknown file:
0 (%resolve-variable (7 . qtbase) #<directory (gnu packages kde) 7f68d6175b40>)
ERROR: In procedure %resolve-variable:
error: qtbase: unbound variable
------
master
parent
5f63905096
commit
e61b3bcd79
|
@ -1489,7 +1489,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/qrcodegen-cpp-make-install.patch \
|
%D%/packages/patches/qrcodegen-cpp-make-install.patch \
|
||||||
%D%/packages/patches/qt4-ldflags.patch \
|
%D%/packages/patches/qt4-ldflags.patch \
|
||||||
%D%/packages/patches/qtbase-absolute-runpath.patch \
|
%D%/packages/patches/qtbase-absolute-runpath.patch \
|
||||||
%D%/packages/patches/qtbase-fix-krita-deadlock.patch \
|
|
||||||
%D%/packages/patches/qtbase-moc-ignore-gcc-macro.patch \
|
%D%/packages/patches/qtbase-moc-ignore-gcc-macro.patch \
|
||||||
%D%/packages/patches/qtbase-use-TZDIR.patch \
|
%D%/packages/patches/qtbase-use-TZDIR.patch \
|
||||||
%D%/packages/patches/qtscript-disable-tests.patch \
|
%D%/packages/patches/qtscript-disable-tests.patch \
|
||||||
|
|
|
@ -360,14 +360,6 @@ a module for implementing ODF Gantt charts, which are bar charts that
|
||||||
illustrate project schedules.")
|
illustrate project schedules.")
|
||||||
(license license:gpl2+)))
|
(license license:gpl2+)))
|
||||||
|
|
||||||
(define qtbase-for-krita
|
|
||||||
(package
|
|
||||||
(inherit qtbase)
|
|
||||||
(source (origin
|
|
||||||
(inherit (package-source qtbase))
|
|
||||||
(patches (append (origin-patches (package-source qtbase))
|
|
||||||
(search-patches "qtbase-fix-krita-deadlock.patch")))))))
|
|
||||||
|
|
||||||
(define-public krita
|
(define-public krita
|
||||||
(package
|
(package
|
||||||
(name "krita")
|
(name "krita")
|
||||||
|
@ -442,7 +434,7 @@ illustrate project schedules.")
|
||||||
("openexr" ,openexr)
|
("openexr" ,openexr)
|
||||||
("perl" ,perl)
|
("perl" ,perl)
|
||||||
("poppler-qt5" ,poppler-qt5)
|
("poppler-qt5" ,poppler-qt5)
|
||||||
("qtbase" ,qtbase-for-krita)
|
("qtbase" ,qtbase)
|
||||||
("qtdeclarative" ,qtdeclarative)
|
("qtdeclarative" ,qtdeclarative)
|
||||||
("qtmultimedia" ,qtmultimedia)
|
("qtmultimedia" ,qtmultimedia)
|
||||||
("qtsvg" ,qtsvg)
|
("qtsvg" ,qtsvg)
|
||||||
|
|
|
@ -1,110 +0,0 @@
|
||||||
Fix a deadlock in Krita:
|
|
||||||
|
|
||||||
https://bugreports.qt.io/browse/QTBUG-83207
|
|
||||||
|
|
||||||
Patch copied from Qt bug tracker:
|
|
||||||
|
|
||||||
https://codereview.qt-project.org/c/qt/qtbase/+/296034
|
|
||||||
|
|
||||||
From 276fa8383a7535765be7182883ef4aade17ce013 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Thiago Macieira <thiago.macieira@intel.com>
|
|
||||||
Date: Thu, 02 Apr 2020 12:08:41 -0300
|
|
||||||
Subject: [PATCH] QLibrary: fix deadlock caused by fix to QTBUG-39642
|
|
||||||
|
|
||||||
Commit ae6f73e8566fa76470937aca737141183929a5ec inserted a mutex around
|
|
||||||
the entire load_sys(). We had reasoed that deadlocks would only occur if
|
|
||||||
the object creation in instance() recursed into its own instance(),
|
|
||||||
which was already a bug. But we had forgotten that dlopen()/
|
|
||||||
LoadLibrary() executes initialization code from the module being loaded,
|
|
||||||
which could cause a recursion back into the same QPluginLoader or
|
|
||||||
QLibrary object. This recursion is benign because the module *is* loaded
|
|
||||||
and dlopen()/LoadLibrary() returns the same handle.
|
|
||||||
|
|
||||||
[ChangeLog][QtCore][QLibrary and QPluginLoader] Fixed a deadlock that
|
|
||||||
would happen if the plugin or library being loaded has load-time
|
|
||||||
initialization code (C++ global variables) that recursed back into the
|
|
||||||
same QLibrary or QPluginLoader object.
|
|
||||||
|
|
||||||
PS: QLibraryPrivate::loadPlugin() updates pluginState outside a mutex
|
|
||||||
lock, so pluginState should be made an atomic variable. Once that is
|
|
||||||
done, we'll only need locking the mutex to update errorString (no
|
|
||||||
locking before loading).
|
|
||||||
|
|
||||||
Fixes: QTBUG-83207
|
|
||||||
Task-number: QTBUG-39642
|
|
||||||
Change-Id: Ibdc95e9af7bd456a94ecfffd160209304e5ab2eb
|
|
||||||
Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
|
|
||||||
Reviewed-by: David Faure <david.faure@kdab.com>
|
|
||||||
---
|
|
||||||
|
|
||||||
diff --git a/src/corelib/plugin/qlibrary.cpp b/src/corelib/plugin/qlibrary.cpp
|
|
||||||
index ddb053c..be9d92b 100644
|
|
||||||
--- a/src/corelib/plugin/qlibrary.cpp
|
|
||||||
+++ b/src/corelib/plugin/qlibrary.cpp
|
|
||||||
@@ -576,9 +576,7 @@
|
|
||||||
|
|
||||||
Q_TRACE(QLibraryPrivate_load_entry, fileName);
|
|
||||||
|
|
||||||
- mutex.lock();
|
|
||||||
bool ret = load_sys();
|
|
||||||
- mutex.unlock();
|
|
||||||
if (qt_debug_component()) {
|
|
||||||
if (ret) {
|
|
||||||
qDebug() << "loaded library" << fileName;
|
|
||||||
diff --git a/src/corelib/plugin/qlibrary_unix.cpp b/src/corelib/plugin/qlibrary_unix.cpp
|
|
||||||
index 017aa97..a5c72f8 100644
|
|
||||||
--- a/src/corelib/plugin/qlibrary_unix.cpp
|
|
||||||
+++ b/src/corelib/plugin/qlibrary_unix.cpp
|
|
||||||
@@ -123,6 +123,7 @@
|
|
||||||
|
|
||||||
bool QLibraryPrivate::load_sys()
|
|
||||||
{
|
|
||||||
+ QMutexLocker locker(&mutex);
|
|
||||||
QString attempt;
|
|
||||||
QFileSystemEntry fsEntry(fileName);
|
|
||||||
|
|
||||||
@@ -213,6 +214,7 @@
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+ locker.unlock();
|
|
||||||
bool retry = true;
|
|
||||||
Handle hnd = nullptr;
|
|
||||||
for (int prefix = 0; retry && !hnd && prefix < prefixes.size(); prefix++) {
|
|
||||||
@@ -273,6 +275,8 @@
|
|
||||||
}
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
+
|
|
||||||
+ locker.relock();
|
|
||||||
if (!hnd) {
|
|
||||||
errorString = QLibrary::tr("Cannot load library %1: %2").arg(fileName, qdlerror());
|
|
||||||
}
|
|
||||||
diff --git a/src/corelib/plugin/qlibrary_win.cpp b/src/corelib/plugin/qlibrary_win.cpp
|
|
||||||
index 000bf76..ef58724 100644
|
|
||||||
--- a/src/corelib/plugin/qlibrary_win.cpp
|
|
||||||
+++ b/src/corelib/plugin/qlibrary_win.cpp
|
|
||||||
@@ -78,6 +78,7 @@
|
|
||||||
// fileName
|
|
||||||
//
|
|
||||||
// NB If it's a plugin we do not ever try the ".dll" extension
|
|
||||||
+ QMutexLocker locker(&mutex);
|
|
||||||
QStringList attempts;
|
|
||||||
|
|
||||||
if (pluginState != IsAPlugin)
|
|
||||||
@@ -95,6 +96,7 @@
|
|
||||||
attempts.prepend(QDir::rootPath() + fileName);
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+ locker.unlock();
|
|
||||||
Handle hnd = nullptr;
|
|
||||||
for (const QString &attempt : qAsConst(attempts)) {
|
|
||||||
#ifndef Q_OS_WINRT
|
|
||||||
@@ -115,6 +117,7 @@
|
|
||||||
#ifndef Q_OS_WINRT
|
|
||||||
SetErrorMode(oldmode);
|
|
||||||
#endif
|
|
||||||
+ locker.relock();
|
|
||||||
if (!hnd) {
|
|
||||||
errorString = QLibrary::tr("Cannot load library %1: %2").arg(
|
|
||||||
QDir::toNativeSeparators(fileName), qt_error_string());
|
|
|
@ -342,7 +342,6 @@ developers using C++ or QML, a CSS & JavaScript like language.")
|
||||||
(define-public qtbase
|
(define-public qtbase
|
||||||
(package
|
(package
|
||||||
(name "qtbase")
|
(name "qtbase")
|
||||||
;; TODO Remove ((gnu packages kde) qtbase-for-krita) when upgrading qtbase.
|
|
||||||
(version "5.14.2")
|
(version "5.14.2")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
|
Reference in New Issue