me
/
guix
Archived
1
0
Fork 0

gnu: tor: Update to 0.4.6.5.

* gnu/packages/tor.scm (tor): Update to 0.4.6.5.
[source]: Add a patch to fix building with GCC 7.
* gnu/packages/patches/tor-fix-build-with-gcc-7.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
master
Tobias Geerinckx-Rice 2021-06-14 23:15:39 +02:00
parent 748d3a2b8a
commit e7aac78ee9
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 34 additions and 2 deletions

View File

@ -1745,6 +1745,7 @@ dist_patch_DATA = \
%D%/packages/patches/tipp10-qt5.patch \
%D%/packages/patches/tk-find-library.patch \
%D%/packages/patches/tla2tools-build-xml.patch \
%D%/packages/patches/tor-fix-build-with-gcc-7.patch \
%D%/packages/patches/transcode-ffmpeg.patch \
%D%/packages/patches/transmission-honor-localedir.patch \
%D%/packages/patches/ttf2eot-cstddef.patch \

View File

@ -0,0 +1,30 @@
From 810c0616d59809b89f5144d4afdbf70391df7a7f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Alexander=20F=C3=A6r=C3=B8y?= <ahf@torproject.org>
Date: Thu, 10 Jun 2021 20:04:13 +0000
Subject: [PATCH] Fix compilation on OpenSUSE.
This patch fixes a build error with GCC 7.x which doesn't seem to accept
const int's as constants in macro initialization.
See: tpo/core/tor#40410
---
src/feature/dirclient/dirclient.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/src/feature/dirclient/dirclient.c b/src/feature/dirclient/dirclient.c
index 74c6452061..a2b20621a0 100644
--- a/src/feature/dirclient/dirclient.c
+++ b/src/feature/dirclient/dirclient.c
@@ -1907,8 +1907,7 @@ dir_client_decompress_response_body(char **bodyp, size_t *bodylenp,
/* If we're pretty sure that we have a compressed directory, and
* we didn't manage to uncompress it, then warn and bail. */
if (!plausible && !new_body) {
- const int LOG_INTERVAL = 3600;
- static ratelim_t warning_limit = RATELIM_INIT(LOG_INTERVAL);
+ static ratelim_t warning_limit = RATELIM_INIT(60 * 60);
log_fn_ratelim(&warning_limit, LOG_WARN, LD_HTTP,
"Unable to decompress HTTP body (tried %s%s%s, on %s).",
description1,
--
GitLab

View File

@ -54,14 +54,15 @@
(define-public tor
(package
(name "tor")
(version "0.4.5.9")
(version "0.4.6.5")
(source (origin
(method url-fetch)
(uri (string-append "https://dist.torproject.org/tor-"
version ".tar.gz"))
(sha256
(base32
"0mh8yz6l7sl6kh9max76nk6rhlsq2lhwwvpiwlwnrlif21bf817k"))))
"1yacd7h7wg8n6wwrjmx2g9xjj24kj08j5sai9g7fm4cp1m73avbv"))
(patches (search-patches "tor-fix-build-with-gcc-7.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags