me
/
guix
Archived
1
0
Fork 0

gnu: gnunet: Fix libmicrohttpd test case using SSL3.

* gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch:
Patch for failing test case as suggested by libmicrohttpd mailing list
* gnu/packages/gnunet.scm (libmicrohttpd): use patch
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
master
muradm 2021-09-17 09:26:48 +03:00 committed by Ludovic Courtès
parent c3892d4ffb
commit e8d80d0456
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 38 additions and 1 deletions

View File

@ -1363,6 +1363,7 @@ dist_patch_DATA = \
%D%/packages/patches/libmad-length-check.patch \
%D%/packages/patches/libmad-md_size.patch \
%D%/packages/patches/libmad-mips-newgcc.patch \
%D%/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch \
%D%/packages/patches/libmp4v2-c++11.patch \
%D%/packages/patches/libmpeg2-arm-private-symbols.patch \
%D%/packages/patches/libmpeg2-global-symbol-test.patch \

View File

@ -164,7 +164,8 @@ tool to extract metadata from a file and print the results.")
version ".tar.gz"))
(sha256
(base32
"0bh39irwzkv48fkw43skfgkk8ka3793bx1lm21sgw6zxi0djyyx3"))))
"0bh39irwzkv48fkw43skfgkk8ka3793bx1lm21sgw6zxi0djyyx3"))
(patches (search-patches "libmicrohttpd-0.9.73-test-ssl3.patch"))))
(build-system gnu-build-system)
(inputs
`(("curl" ,curl)

View File

@ -0,0 +1,35 @@
Disable usage of SSLv3 in testing
Integrated uptream version 0.9.74
diff --git a/src/testcurl/https/test_tls_options.c b/src/testcurl/https/test_tls_options.c
--- a/src/testcurl/https/test_tls_options.c
+++ b/src/testcurl/https/test_tls_options.c
@@ -119,11 +119,6 @@ main (int argc, char *const *argv)
fprintf (stderr, "Curl does not support SSL. Cannot run the test.\n");
return 77;
}
- if (0 != strncmp (ssl_version, "GnuTLS", 6))
- {
- fprintf (stderr, "This test can be run only with libcurl-gnutls.\n");
- return 77;
- }
if (! testsuite_curl_global_init ())
return 99;
@@ -152,10 +147,10 @@ main (int argc, char *const *argv)
fprintf (stderr,
"The following handshake should fail (and print an error message)...\n");
if (0 !=
- test_wrap ("TLS1.0 vs SSL3",
+ test_wrap ("TLS1.1 vs TLS1.0",
&test_unmatching_ssl_version, NULL, port, daemon_flags,
aes256_sha,
- CURL_SSLVERSION_SSLv3,
+ CURL_SSLVERSION_TLSv1_1,
MHD_OPTION_HTTPS_MEM_KEY, srv_key_pem,
MHD_OPTION_HTTPS_MEM_CERT, srv_self_signed_cert_pem,
MHD_OPTION_HTTPS_PRIORITIES,