me
/
guix
Archived
1
0
Fork 0

gnu: azr3: Update to 1.2.3-1.3391a0a.

* gnu/packages/audio.scm (azr3): Update to 1.2.3-1.3391a0a.
[arguments]: Replace bootstrap phase.
* gnu/packages/patches/azr3-remove-lash.patch,
gnu/packages/patches/azr3.patch: Update patches.
master
Ricardo Wurmus 2023-02-07 11:09:42 +01:00
parent fb3dfff677
commit e8f4ce7428
No known key found for this signature in database
GPG Key ID: 197A5888235FACAC
3 changed files with 53 additions and 43 deletions

View File

@ -1091,46 +1091,56 @@ formant warp.")
(license license:gpl2+))) (license license:gpl2+)))
(define-public azr3 (define-public azr3
(package (let ((commit "3391a0a509e7fa3fb46c7627fd5979b67e468038")
(name "azr3") (revision "1"))
(version "1.2.3") (package
(source (origin (name "azr3")
(method url-fetch) (version (git-version "1.2.3" revision commit))
(uri (string-append "mirror://savannah/ll-plugins/azr3-jack-" (source (origin
version (method git-fetch)
".tar.bz2")) (uri (git-reference
(sha256 (url "https://git.savannah.gnu.org/git/ll-plugins/azr3-jack.git")
(base32 (commit commit)))
"18mdw6nc0vgj6k9rsy0x8w64wvzld0frqshrxxbxfj9qi9843vlc")) (file-name (git-file-name name version))
(patches (search-patches "azr3.patch" (sha256
"azr3-remove-lash.patch")))) (base32
(build-system gnu-build-system) "09wy0z4kiid7mwf5b5j8rzzgxafi4mg88xs550n7864p0n351chx"))
(arguments (patches (search-patches "azr3.patch"
(list "azr3-remove-lash.patch"))))
#:tests? #f ; no check target (build-system gnu-build-system)
#:make-flags (arguments
#~(list "LV2PEG=ttl2c" (list
(string-append "prefix=" #$output) #:tests? #f ; no check target
(string-append "pkgdatadir=" #$output "/share/azr3-jack")) #:make-flags
#:phases #~(list "LV2PEG=ttl2c"
'(modify-phases %standard-phases (string-append "prefix=" #$output)
(add-before 'install 'fix-timestamp (string-append "pkgdatadir=" #$output "/share/azr3-jack"))
(lambda _ #:phases
(let ((early-1980 315619200)) ; 1980-01-02 UTC #~(modify-phases %standard-phases
(utime "azr3.1" early-1980 early-1980))))))) (replace 'bootstrap
(inputs (lambda _
(list gtkmm-2 lvtk jack-1)) (call-with-output-file "Makefile.config"
(native-inputs (lambda (port) (display "" port)))
(list pkg-config)) (substitute* "Makefile"
(home-page "http://ll-plugins.nongnu.org/azr3/") (("^PACKAGE_VERSION =.*")
(synopsis "Tonewheel organ synthesizer") (string-append "PACKAGE_VERSION = \"" #$version "\"\n")))))
(description (add-before 'install 'fix-timestamp
"AZR-3 is a port of the free VST plugin AZR-3. It is a tonewheel organ (lambda _
(let ((early-1980 315619200)) ; 1980-01-02 UTC
(utime "azr3.1" early-1980 early-1980)))))))
(inputs
(list gtkmm-2 lvtk jack-1))
(native-inputs
(list pkg-config))
(home-page "http://ll-plugins.nongnu.org/azr3/")
(synopsis "Tonewheel organ synthesizer")
(description
"AZR-3 is a port of the free VST plugin AZR-3. It is a tonewheel organ
with drawbars, distortion and rotating speakers. The organ has three with drawbars, distortion and rotating speakers. The organ has three
sections, two polyphonic sections with nine drawbars each and one monophonic sections, two polyphonic sections with nine drawbars each and one monophonic
bass section with five drawbars. A standalone JACK application and LV2 bass section with five drawbars. A standalone JACK application and LV2
plugins are provided.") plugins are provided.")
(license license:gpl2))) (license license:gpl2))))
(define-public calf (define-public calf
(package (package

View File

@ -19,7 +19,7 @@ index 7c9f4f0..f82ba75 100644
textbox.hpp textbox.cpp textbox.hpp textbox.cpp
azr3_SOURCEDIR = azr3 azr3_SOURCEDIR = azr3
-azr3_CFLAGS = `pkg-config --cflags gtkmm-2.4 jack lash-1.0` -DDATADIR=\"$(pkgdatadir)\" -azr3_CFLAGS = `pkg-config --cflags gtkmm-2.4 jack lash-1.0` -DDATADIR=\"$(pkgdatadir)\"
-azr3_LDFLAGS = `pkg-config --libs gtkmm-2.4 jack lash-1.0` -azr3_LDFLAGS = `pkg-config --libs gtkmm-2.4 jack lash-1.0` -lpthread
+azr3_CFLAGS = `pkg-config --cflags gtkmm-2.4 jack` -DDATADIR=\"$(pkgdatadir)\" +azr3_CFLAGS = `pkg-config --cflags gtkmm-2.4 jack` -DDATADIR=\"$(pkgdatadir)\"
+azr3_LDFLAGS = `pkg-config --libs gtkmm-2.4 jack` -lpthread +azr3_LDFLAGS = `pkg-config --libs gtkmm-2.4 jack` -lpthread
azr3_cpp_CFLAGS = $(shell if pkg-config --atleast-version=0.107 jack ; then echo -include azr3/newjack.hpp; fi) azr3_cpp_CFLAGS = $(shell if pkg-config --atleast-version=0.107 jack ; then echo -include azr3/newjack.hpp; fi)

View File

@ -68,9 +68,9 @@ The patch has been sent to the developer on 2016-09-26.
Widget* eb = add_clickbox(m_fbox, 14, 319, 14, 44); Widget* eb = add_clickbox(m_fbox, 14, 319, 14, 44);
eb->signal_button_press_event(). eb->signal_button_press_event().
- connect(sigc::hide(bind(bind(mem_fun(*this, &AZR3GUI::change_mode), - connect(sigc::hide(bind(bind(mem_fun(*this, &AZR3GUI::change_mode),
- ref(m_fbox)), false))); - sigc::ref(m_fbox)), false)));
+ connect(sigc::hide(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::change_mode), + connect(sigc::hide(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::change_mode),
+ false, std::ref(m_fbox)))); + false, sigc::ref(m_fbox))));
m_fx_widgets.push_back(eb); m_fx_widgets.push_back(eb);
// Mr Valve controls // Mr Valve controls
@ -79,15 +79,15 @@ The patch has been sent to the developer on 2016-09-26.
Widget* eb2 = add_clickbox(m_vbox, 14, 53, 14, 44); Widget* eb2 = add_clickbox(m_vbox, 14, 53, 14, 44);
eb2->signal_button_press_event(). eb2->signal_button_press_event().
- connect(sigc::hide(bind(bind(mem_fun(*this, &AZR3GUI::change_mode), - connect(sigc::hide(bind(bind(mem_fun(*this, &AZR3GUI::change_mode),
- ref(m_fbox)), true))); - sigc::ref(m_fbox)), true)));
+ connect(sigc::hide(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::change_mode), + connect(sigc::hide(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::change_mode),
+ true, std::ref(m_fbox)))); + true, sigc::ref(m_fbox))));
// vibrato controls // vibrato controls
add_switch(m_vbox, n_1_vibrato, 39, 17, Switch::Green); add_switch(m_vbox, n_1_vibrato, 39, 17, Switch::Green);
@@ -352,9 +352,9 @@ @@ -352,9 +352,9 @@
knob->set_style(s); knob->set_style(s);
if (port >= 0 && port < m_adj.size()) { if (port < m_adj.size()) {
knob->get_adjustment().signal_value_changed(). knob->get_adjustment().signal_value_changed().
- connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed), port), - connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed), port),
- mem_fun(knob->get_adjustment(), - mem_fun(knob->get_adjustment(),
@ -100,7 +100,7 @@ The patch has been sent to the developer on 2016-09-26.
} }
@@ -382,8 +382,8 @@ @@ -382,8 +382,8 @@
db->set_style(s); db->set_style(s);
if (port >= 0 && port < m_adj.size()) { if (port < m_adj.size()) {
db->get_adjustment().signal_value_changed(). db->get_adjustment().signal_value_changed().
- connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed), port), - connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed), port),
- mem_fun(db->get_adjustment(), &Adjustment::get_value))); - mem_fun(db->get_adjustment(), &Adjustment::get_value)));