From eb564fc389f23ae21a1bf07f6c9f4f454a4abbe3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Tue, 7 Oct 2014 10:31:45 +0200
Subject: [PATCH] gnu: eudev: Really update to 1.10.

* gnu/packages/linux.scm (eudev)[version]: Fix typo.
  [source]: Add 'snippet'.
---
 gnu/packages/linux.scm | 13 +++++++++++--
 1 file changed, 11 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6d9073d063..37324f9bb3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1387,7 +1387,7 @@ time.")
   ;; The post-systemd fork, maintained by Gentoo.
   (package (inherit udev)
     (name "eudev")
-    (version "1.`0")
+    (version "1.10")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -1396,7 +1396,16 @@ time.")
               (sha256
                (base32
                 "1l907bvz6dcykvaq8d4iklvfpb9fyrnh1a29g3c28gkx2hlyn7j0"))
-              (patches (list (search-patch "eudev-rules-directory.patch")))))
+              (patches (list (search-patch "eudev-rules-directory.patch")))
+              (modules '((guix build utils)))
+              (snippet
+               ;; 'configure' checks uses <linux/btrfs.h> as an indication of
+               ;; whether Linux headers are available, but it doesn't actually
+               ;; use it, and our 'linux-libre-headers' package doesn't
+               ;; provide it.  So just remove that.
+               '(substitute* "configure"
+                  (("linux/btrfs\\.h")
+                   "")))))
     (arguments
      (substitute-keyword-arguments (package-arguments udev)
        ((#:configure-flags flags)