gnu: icu4c: Fix failing test.
* gnu/packages/patches/icu4c-test-date-format.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/icu4c.scm (icu4c)[source]: Use it.master
parent
b344c505f4
commit
eb705bb3f7
|
@ -314,6 +314,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/guix-test-networking.patch \
|
||||
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
gnu/packages/patches/hop-bigloo-4.0b.patch \
|
||||
gnu/packages/patches/icu4c-test-date-format.patch \
|
||||
gnu/packages/patches/inkscape-stray-comma.patch \
|
||||
gnu/packages/patches/libevent-dns-tests.patch \
|
||||
gnu/packages/patches/libffi-mips-n32-fix.patch \
|
||||
|
|
|
@ -37,7 +37,8 @@
|
|||
(string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
|
||||
"-src.tgz"))
|
||||
(sha256 (base32
|
||||
"14l0kl17nirc34frcybzg0snknaks23abhdxkmsqg3k9sil5wk9g"))))
|
||||
"14l0kl17nirc34frcybzg0snknaks23abhdxkmsqg3k9sil5wk9g")))
|
||||
(patches (list (search-patch "icu4c-test-date-format.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("patchelf" ,patchelf)
|
||||
|
|
|
@ -0,0 +1,17 @@
|
|||
Starting with the switch to GCC 4.8.3, we observed this test failure.
|
||||
Changing "34" to "134" means that we expect the date to be parsed as
|
||||
"2034", not "1934", which seems consistent with the line above.
|
||||
|
||||
Reported at <http://bugs.icu-project.org/trac/ticket/10960>.
|
||||
|
||||
--- icu/source/test/intltest/dtfmttst.cpp 2014-06-16 10:35:46.000000000 +0200
|
||||
+++ icu/source/test/intltest/dtfmttst.cpp 2014-06-16 10:35:52.000000000 +0200
|
||||
@@ -1129,7 +1129,7 @@ DateFormatTest::TestTwoDigitYear()
|
||||
return;
|
||||
}
|
||||
parse2DigitYear(fmt, "5/6/17", date(117, UCAL_JUNE, 5));
|
||||
- parse2DigitYear(fmt, "4/6/34", date(34, UCAL_JUNE, 4));
|
||||
+ parse2DigitYear(fmt, "4/6/34", date(134, UCAL_JUNE, 4));
|
||||
}
|
||||
|
||||
// -------------------------------------
|
Reference in New Issue