gnu: flex: Fix CVE-2016-6354.
* gnu/packages/flex.scm (flex)[source]: Add patch. * gnu/packages/patches/flex-CVE-2016-6354.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.master
parent
4ea1ad9108
commit
eba7fab890
|
@ -504,6 +504,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/findutils-localstatedir.patch \
|
%D%/packages/patches/findutils-localstatedir.patch \
|
||||||
%D%/packages/patches/findutils-test-xargs.patch \
|
%D%/packages/patches/findutils-test-xargs.patch \
|
||||||
%D%/packages/patches/flashrom-use-libftdi1.patch \
|
%D%/packages/patches/flashrom-use-libftdi1.patch \
|
||||||
|
%D%/packages/patches/flex-CVE-2016-6354.patch \
|
||||||
%D%/packages/patches/flint-ldconfig.patch \
|
%D%/packages/patches/flint-ldconfig.patch \
|
||||||
%D%/packages/patches/fltk-shared-lib-defines.patch \
|
%D%/packages/patches/fltk-shared-lib-defines.patch \
|
||||||
%D%/packages/patches/fltk-xfont-on-demand.patch \
|
%D%/packages/patches/fltk-xfont-on-demand.patch \
|
||||||
|
|
|
@ -36,6 +36,7 @@
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://sourceforge/flex/flex-"
|
(uri (string-append "mirror://sourceforge/flex/flex-"
|
||||||
version ".tar.bz2"))
|
version ".tar.bz2"))
|
||||||
|
(patches (search-patches "flex-CVE-2016-6354.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1sdqx63yadindzafrq1w31ajblf9gl1c301g068s20s7bbpi3ri4"))))
|
"1sdqx63yadindzafrq1w31ajblf9gl1c301g068s20s7bbpi3ri4"))))
|
||||||
|
|
|
@ -0,0 +1,30 @@
|
||||||
|
Fix CVE-2016-6354 (Buffer overflow in generated code (yy_get_next_buffer).
|
||||||
|
|
||||||
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-6354
|
||||||
|
https://security-tracker.debian.org/tracker/CVE-2016-6354
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
https://github.com/westes/flex/commit/a5cbe929ac3255d371e698f62dc256afe7006466
|
||||||
|
|
||||||
|
From a5cbe929ac3255d371e698f62dc256afe7006466 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Will Estes <westes575@gmail.com>
|
||||||
|
Date: Sat, 27 Feb 2016 11:56:05 -0500
|
||||||
|
Subject: [PATCH] Fixed incorrect integer type
|
||||||
|
|
||||||
|
---
|
||||||
|
src/flex.skl | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/flex.skl b/src/flex.skl
|
||||||
|
index 36a526a..64f853d 100644
|
||||||
|
--- a/src/flex.skl
|
||||||
|
+++ b/src/flex.skl
|
||||||
|
@@ -1703,7 +1703,7 @@ int yyFlexLexer::yy_get_next_buffer()
|
||||||
|
|
||||||
|
else
|
||||||
|
{
|
||||||
|
- yy_size_t num_to_read =
|
||||||
|
+ int num_to_read =
|
||||||
|
YY_CURRENT_BUFFER_LVALUE->yy_buf_size - number_to_move - 1;
|
||||||
|
|
||||||
|
while ( num_to_read <= 0 )
|
Reference in New Issue