gnu: emacs-elpy: Update to 1.35.0-2.7ff8ffa.
* gnu/packages/emacs-xyz.scm (emacs-elpy): Update to 1.35.0-2.7ff8ffa. [origin]: Apply patch. [arguments]: Disable a new test in the disable-broken-tests phase. * gnu/packages/patches/emacs-elpy-dup-test-name.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.master
parent
22d2f94eb2
commit
ecb1b335d4
|
@ -1097,6 +1097,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-all-the-icons-remove-duplicate-rs.patch \
|
||||
%D%/packages/patches/emacs-debbugs-keep-patch-subject.patch \
|
||||
%D%/packages/patches/emacs-deferred-fix-number-of-arguments.patch \
|
||||
%D%/packages/patches/emacs-elpy-dup-test-name.patch \
|
||||
%D%/packages/patches/emacs-exec-path.patch \
|
||||
%D%/packages/patches/emacs-ess-fix-obsolete-function-alias.patch \
|
||||
%D%/packages/patches/emacs-git-email-missing-parens.patch \
|
||||
|
|
|
@ -14306,8 +14306,8 @@ indentation guides in Emacs:
|
|||
;; https://github.com/jorgenschaefer/elpy/issues/1824
|
||||
;; https://github.com/jorgenschaefer/elpy/pull/1951
|
||||
;; https://github.com/jorgenschaefer/elpy/issues/1940.
|
||||
(let ((commit "1746e7009000b7635c0ea6f1559018143aa61642")
|
||||
(revision "1"))
|
||||
(let ((commit "7ff8ffa918411887d165764f7a5a12bc46646e73")
|
||||
(revision "2"))
|
||||
(package
|
||||
(name "emacs-elpy")
|
||||
(version (git-version "1.35.0" revision commit))
|
||||
|
@ -14319,7 +14319,8 @@ indentation guides in Emacs:
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"120xzzaa8jxls3lri6d53zq6gafnkc6d9mlg09an334kkmh8k2fc"))))
|
||||
"0lh8w5a1abxaa7lf1c4yzgr0sh9szcwdnwd8w2004hv6mrcmyqc6"))
|
||||
(patches (search-patches "emacs-elpy-dup-test-name.patch"))))
|
||||
(build-system emacs-build-system)
|
||||
(arguments
|
||||
`(#:include (cons* "^elpy/[^/]+\\.py$" "^snippets\\/" %default-include)
|
||||
|
@ -14354,6 +14355,12 @@ indentation guides in Emacs:
|
|||
(string-append all " :expected-result :failed\n")))
|
||||
(substitute* "elpy-shell-echo-inputs-and-outputs-test.el"
|
||||
(("elpy-shell-should-echo-outputs.*" all)
|
||||
(string-append all " :expected-result :failed\n")))
|
||||
;; This test started failing with Emacs 29 (see:
|
||||
;; https://github.com/jorgenschaefer/elpy/issues/2032).
|
||||
(substitute* "elpy-folding-fold-blocks-test.el"
|
||||
(("elpy-fold-at-point-should-NOT-fold-and-unfold-functions\
|
||||
-from-after.*" all)
|
||||
(string-append all " :expected-result :failed\n"))))))
|
||||
;; The default environment of the RPC uses Virtualenv to install
|
||||
;; Python dependencies from PyPI. We don't want/need this in Guix.
|
||||
|
|
|
@ -0,0 +1,60 @@
|
|||
Forwarded upstream: https://github.com/jorgenschaefer/elpy/pull/2031
|
||||
|
||||
diff --git a/test/elpy-config--insert-help-test.el b/test/elpy-config--insert-help-test.el
|
||||
index bb293ff..2584fd4 100644
|
||||
--- a/test/elpy-config--insert-help-test.el
|
||||
+++ b/test/elpy-config--insert-help-test.el
|
||||
@@ -2,6 +2,6 @@
|
||||
;; with output. We will test its constituent functions later, and just
|
||||
;; make sure it doesn't throw an error here.
|
||||
|
||||
-(ert-deftest elpy-config-should-not-fail ()
|
||||
+(ert-deftest elpy-config-should-not-fail-insert-help ()
|
||||
(elpy-testcase ()
|
||||
(elpy-config--insert-help)))
|
||||
diff --git a/test/elpy-library-root-test.el b/test/elpy-library-root-test.el
|
||||
index fdc88b2..2f7484c 100644
|
||||
--- a/test/elpy-library-root-test.el
|
||||
+++ b/test/elpy-library-root-test.el
|
||||
@@ -4,7 +4,7 @@
|
||||
(should (f-equal? (elpy-library-root)
|
||||
project-root))))
|
||||
|
||||
-(ert-deftest elpy-library-root-should-find-current-directory ()
|
||||
+(ert-deftest elpy-library-root-should-find-current-directory-2 ()
|
||||
(elpy-testcase ((:project project-root
|
||||
"p1/p2/test.py"
|
||||
"p1/p2/__init__.py"
|
||||
diff --git a/test/elpy-open-and-indent-line-above-test.el b/test/elpy-open-and-indent-line-above-test.el
|
||||
index d846712..790dd26 100644
|
||||
--- a/test/elpy-open-and-indent-line-above-test.el
|
||||
+++ b/test/elpy-open-and-indent-line-above-test.el
|
||||
@@ -1,4 +1,4 @@
|
||||
-(ert-deftest elpy-open-and-indent-line-below ()
|
||||
+(ert-deftest elpy-open-and-indent-line-above ()
|
||||
(elpy-testcase ()
|
||||
(elpy-enable)
|
||||
(python-mode)
|
||||
diff --git a/test/elpy-rpc-get-usages-test.el b/test/elpy-rpc-get-usages-test.el
|
||||
index 85f0ad4..be5d7c5 100644
|
||||
--- a/test/elpy-rpc-get-usages-test.el
|
||||
+++ b/test/elpy-rpc-get-usages-test.el
|
||||
@@ -1,4 +1,4 @@
|
||||
-(ert-deftest elpy-rpc-get-completions ()
|
||||
+(ert-deftest elpy-rpc-get-completions-usages ()
|
||||
(elpy-testcase ()
|
||||
(mletf* ((called-args nil)
|
||||
(elpy-rpc (&rest args) (setq called-args args)))
|
||||
diff --git a/test/elpy-rpc-test.el b/test/elpy-rpc-test.el
|
||||
index 8b5bdca..3ff6965 100644
|
||||
--- a/test/elpy-rpc-test.el
|
||||
+++ b/test/elpy-rpc-test.el
|
||||
@@ -17,7 +17,7 @@
|
||||
(should (equal error 'elpy-rpc--default-error-callback))))
|
||||
(elpy-rpc "test-method" nil 'success))))
|
||||
|
||||
-(ert-deftest elpy-rpc-should-use-default-without-error-callback ()
|
||||
+(ert-deftest elpy-rpc-should-use-default-without-error-callback-2 ()
|
||||
(elpy-testcase ()
|
||||
(mletf* ((elpy-rpc--call-blocking
|
||||
(method params)
|
Reference in New Issue