gnu: libphonenumber: Build reproducibly.
* gnu/packages/messaging.scm (libphonenumber): Add patch. * gnu/packages/patches/libphonenumber-reproducible-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
parent
d10effc13f
commit
ecb91c993d
|
@ -1412,6 +1412,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libmpeg2-global-symbol-test.patch \
|
%D%/packages/patches/libmpeg2-global-symbol-test.patch \
|
||||||
%D%/packages/patches/libmygpo-qt-fix-qt-5.11.patch \
|
%D%/packages/patches/libmygpo-qt-fix-qt-5.11.patch \
|
||||||
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
|
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
|
||||||
|
%D%/packages/patches/libphonenumber-reproducible-build.patch \
|
||||||
%D%/packages/patches/libqalculate-3.8.0-libcurl-ssl-fix.patch \
|
%D%/packages/patches/libqalculate-3.8.0-libcurl-ssl-fix.patch \
|
||||||
%D%/packages/patches/libquicktime-ffmpeg.patch \
|
%D%/packages/patches/libquicktime-ffmpeg.patch \
|
||||||
%D%/packages/patches/librecad-support-for-boost-1.76.patch \
|
%D%/packages/patches/librecad-support-for-boost-1.76.patch \
|
||||||
|
|
|
@ -2782,6 +2782,8 @@ asynchronicity.")
|
||||||
(url "https://github.com/google/libphonenumber")
|
(url "https://github.com/google/libphonenumber")
|
||||||
(commit (string-append "v" version))))
|
(commit (string-append "v" version))))
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
|
(patches (search-patches
|
||||||
|
"libphonenumber-reproducible-build.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"06y3mh1d1mks6d0ynxp3980g712nkf8l5nyljpybsk326b246hg9"))))
|
"06y3mh1d1mks6d0ynxp3980g712nkf8l5nyljpybsk326b246hg9"))))
|
||||||
|
@ -2803,7 +2805,6 @@ validating international phone numbers.")
|
||||||
(home-page "https://github.com/google/libphonenumber")
|
(home-page "https://github.com/google/libphonenumber")
|
||||||
(license license:asl2.0)))
|
(license license:asl2.0)))
|
||||||
|
|
||||||
|
|
||||||
(define-public chatty
|
(define-public chatty
|
||||||
(package
|
(package
|
||||||
(name "chatty")
|
(name "chatty")
|
||||||
|
|
|
@ -0,0 +1,25 @@
|
||||||
|
Author: Antero Mejr <antero@mailbox.org>
|
||||||
|
Upstream status: I didn't report upstream because they don't have an issue tracker and
|
||||||
|
PRs require signing the Google CLA. If someone willing to sign the CLA
|
||||||
|
wants to submit the patch, please go ahead.
|
||||||
|
|
||||||
|
diff --git a/tools/cpp/src/cpp-build/generate_geocoding_data.cc b/tools/cpp/src/cpp-build/generate_geocoding_data.cc
|
||||||
|
index 021cf5c8..5948e140 100644
|
||||||
|
--- a/tools/cpp/src/cpp-build/generate_geocoding_data.cc
|
||||||
|
+++ b/tools/cpp/src/cpp-build/generate_geocoding_data.cc
|
||||||
|
@@ -88,6 +88,7 @@ class DirEntry {
|
||||||
|
|
||||||
|
const std::string& name() const { return name_; }
|
||||||
|
DirEntryKinds kind() const { return kind_; }
|
||||||
|
+ bool operator<(const DirEntry& d) { return name_ < d.name(); }
|
||||||
|
|
||||||
|
private:
|
||||||
|
std::string name_;
|
||||||
|
@@ -115,6 +116,7 @@ bool ListDirectory(const string& path, vector<DirEntry>* entries) {
|
||||||
|
errno = 0;
|
||||||
|
entry = readdir(dir);
|
||||||
|
if (entry == NULL) {
|
||||||
|
+ std::sort(entries->begin(), entries->end());
|
||||||
|
return errno == 0;
|
||||||
|
}
|
||||||
|
if (strcmp(entry->d_name, ".") == 0 || strcmp(entry->d_name, "..") == 0) {
|
Reference in New Issue