gnu: gnome: Add new package gtkglext
* gnu/packages/gnome.scm (gtkglext): New variable. * gnu/packages/patches/gtkglext-disable-disable-deprecated.patch, gnu/packages/patches/gtkglext-remove-pangox-dependency.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>master
parent
96e5085c81
commit
ed19903d56
|
@ -254,6 +254,8 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/guile-linux-syscalls.patch \
|
||||
gnu/packages/patches/guile-relocatable.patch \
|
||||
gnu/packages/patches/guix-test-networking.patch \
|
||||
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
gnu/packages/patches/gtkglext-remove-pangox-dependency.patch \
|
||||
gnu/packages/patches/hop-bigloo-4.0b.patch \
|
||||
gnu/packages/patches/libevent-dns-tests.patch \
|
||||
gnu/packages/patches/libffi-mips-n32-fix.patch \
|
||||
|
|
|
@ -21,6 +21,7 @@
|
|||
#:use-module (guix packages)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages glib)
|
||||
#:use-module (gnu packages gnupg)
|
||||
#:use-module (gnu packages gstreamer)
|
||||
|
@ -468,3 +469,29 @@ demand (lazy) programming language support for C, Python and JS; simplicity of
|
|||
the API")
|
||||
|
||||
(license lgpl2.0+)))
|
||||
|
||||
(define-public gtkglext
|
||||
(package
|
||||
(name "gtkglext")
|
||||
(version "1.2.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/project/gtkglext/gtkglext/"
|
||||
version "/gtkglext-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "1ya4d2j2aacr9ii5zj4ac95fjpdvlm2rg79mgnk7yvl1dcy3y1z5"))
|
||||
(patches (list
|
||||
(search-patch "gtkglext-remove-pangox-dependency.patch")
|
||||
(search-patch "gtkglext-disable-disable-deprecated.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("gtk+" ,gtk+-2)
|
||||
("mesa" ,mesa)
|
||||
("libx11" ,libx11)
|
||||
("libxt" ,libxt)))
|
||||
(native-inputs `(("pkg-config" ,pkg-config)))
|
||||
(home-page "https://projects.gnome.org/gtkglext")
|
||||
(synopsis "OpenGL extension to GTK+.")
|
||||
(description "GtkGLExt is an OpenGL extension to GTK+. It provides
|
||||
additional GDK objects which support OpenGL rendering in GTK+ and GtkWidget
|
||||
API add-ons to make GTK+ widgets OpenGL-capable.")
|
||||
(license lgpl2.1+)))
|
||||
|
|
|
@ -0,0 +1,36 @@
|
|||
Having DISABLE_DEPRECATED flags set in the distribution breaks
|
||||
building with libraries later than those which the maintainer
|
||||
happened to have installed. This patch removes them.
|
||||
|
||||
diff -r -U 3 a/gtk/Makefile.am b/gtk/Makefile.am
|
||||
--- a/gtk/Makefile.am 2003-05-09 15:55:05.000000000 +0200
|
||||
+++ b/gtk/Makefile.am 2013-12-26 15:06:38.000000000 +0100
|
||||
@@ -36,11 +36,7 @@
|
||||
-I$(top_srcdir) \
|
||||
-I$(top_builddir)/gdk \
|
||||
$(GTKGLEXT_DEBUG_FLAGS) \
|
||||
- $(GTKGLEXT_DEP_CFLAGS) \
|
||||
- -DG_DISABLE_DEPRECATED \
|
||||
- -DGDK_DISABLE_DEPRECATED \
|
||||
- -DGDK_PIXBUF_DISABLE_DEPRECATED \
|
||||
- -DGTK_DISABLE_DEPRECATED
|
||||
+ $(GTKGLEXT_DEP_CFLAGS)
|
||||
|
||||
common_ldflags = \
|
||||
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
|
||||
diff -r -U 3 a/gtk/Makefile.in b/gtk/Makefile.in
|
||||
--- a/gtk/Makefile.in 2006-02-05 04:17:42.000000000 +0100
|
||||
+++ b/gtk/Makefile.in 2013-12-26 15:07:00.000000000 +0100
|
||||
@@ -234,11 +234,7 @@
|
||||
-I$(top_srcdir) \
|
||||
-I$(top_builddir)/gdk \
|
||||
$(GTKGLEXT_DEBUG_FLAGS) \
|
||||
- $(GTKGLEXT_DEP_CFLAGS) \
|
||||
- -DG_DISABLE_DEPRECATED \
|
||||
- -DGDK_DISABLE_DEPRECATED \
|
||||
- -DGDK_PIXBUF_DISABLE_DEPRECATED \
|
||||
- -DGTK_DISABLE_DEPRECATED
|
||||
+ $(GTKGLEXT_DEP_CFLAGS)
|
||||
|
||||
|
||||
common_ldflags = \
|
|
@ -0,0 +1,132 @@
|
|||
This patch removes the dependency on pangox which has been deprecated. It
|
||||
achieves the same result as the upstream patch at
|
||||
https://git.gnome.org/browse/gtkglext/commit/?id=df7a7b35b80b395d7ba411c7f727970a46fb0588
|
||||
Like the upstream patch, it removes the functions gdk_gl_font_use_pango_font,
|
||||
and gdk_gl_font_use_pango_font_for_display from the API.
|
||||
|
||||
diff -r -U 3 a/configure b/configure
|
||||
--- a/configure 2006-02-05 04:17:47.000000000 +0100
|
||||
+++ b/configure 2013-12-26 12:55:21.000000000 +0100
|
||||
@@ -19880,14 +19880,12 @@
|
||||
gtk+-2.0 >= 2.0.0 \\
|
||||
gdk-2.0 >= 2.0.0 \\
|
||||
pango >= 1.0.0 \\
|
||||
-pangox >= 1.0.0 \\
|
||||
gmodule-2.0 >= 2.0.0 \\
|
||||
\"") >&5
|
||||
($PKG_CONFIG --exists --print-errors "\
|
||||
gtk+-2.0 >= 2.0.0 \
|
||||
gdk-2.0 >= 2.0.0 \
|
||||
pango >= 1.0.0 \
|
||||
-pangox >= 1.0.0 \
|
||||
gmodule-2.0 >= 2.0.0 \
|
||||
") 2>&5
|
||||
ac_status=$?
|
||||
@@ -19897,7 +19895,6 @@
|
||||
gtk+-2.0 >= 2.0.0 \
|
||||
gdk-2.0 >= 2.0.0 \
|
||||
pango >= 1.0.0 \
|
||||
-pangox >= 1.0.0 \
|
||||
gmodule-2.0 >= 2.0.0 \
|
||||
" 2>/dev/null`
|
||||
else
|
||||
@@ -19916,14 +19913,12 @@
|
||||
gtk+-2.0 >= 2.0.0 \\
|
||||
gdk-2.0 >= 2.0.0 \\
|
||||
pango >= 1.0.0 \\
|
||||
-pangox >= 1.0.0 \\
|
||||
gmodule-2.0 >= 2.0.0 \\
|
||||
\"") >&5
|
||||
($PKG_CONFIG --exists --print-errors "\
|
||||
gtk+-2.0 >= 2.0.0 \
|
||||
gdk-2.0 >= 2.0.0 \
|
||||
pango >= 1.0.0 \
|
||||
-pangox >= 1.0.0 \
|
||||
gmodule-2.0 >= 2.0.0 \
|
||||
") 2>&5
|
||||
ac_status=$?
|
||||
@@ -19933,7 +19928,6 @@
|
||||
gtk+-2.0 >= 2.0.0 \
|
||||
gdk-2.0 >= 2.0.0 \
|
||||
pango >= 1.0.0 \
|
||||
-pangox >= 1.0.0 \
|
||||
gmodule-2.0 >= 2.0.0 \
|
||||
" 2>/dev/null`
|
||||
else
|
||||
@@ -19958,7 +19952,6 @@
|
||||
gtk+-2.0 >= 2.0.0 \
|
||||
gdk-2.0 >= 2.0.0 \
|
||||
pango >= 1.0.0 \
|
||||
-pangox >= 1.0.0 \
|
||||
gmodule-2.0 >= 2.0.0 \
|
||||
"`
|
||||
else
|
||||
@@ -19966,7 +19959,6 @@
|
||||
gtk+-2.0 >= 2.0.0 \
|
||||
gdk-2.0 >= 2.0.0 \
|
||||
pango >= 1.0.0 \
|
||||
-pangox >= 1.0.0 \
|
||||
gmodule-2.0 >= 2.0.0 \
|
||||
"`
|
||||
fi
|
||||
@@ -19977,7 +19969,6 @@
|
||||
gtk+-2.0 >= 2.0.0 \
|
||||
gdk-2.0 >= 2.0.0 \
|
||||
pango >= 1.0.0 \
|
||||
-pangox >= 1.0.0 \
|
||||
gmodule-2.0 >= 2.0.0 \
|
||||
) were not met:
|
||||
|
||||
@@ -19994,7 +19985,6 @@
|
||||
gtk+-2.0 >= 2.0.0 \
|
||||
gdk-2.0 >= 2.0.0 \
|
||||
pango >= 1.0.0 \
|
||||
-pangox >= 1.0.0 \
|
||||
gmodule-2.0 >= 2.0.0 \
|
||||
) were not met:
|
||||
|
||||
@@ -25420,7 +25410,7 @@
|
||||
# CFLAGS and LIBS
|
||||
##################################################
|
||||
|
||||
-GDKGLEXT_PACKAGES="gdk-2.0 pango pangox gmodule-2.0"
|
||||
+GDKGLEXT_PACKAGES="gdk-2.0 pango gmodule-2.0"
|
||||
GDKGLEXT_EXTRA_CFLAGS="$GL_CFLAGS $GDKGLEXT_WIN_CFLAGS"
|
||||
GDKGLEXT_EXTRA_LIBS="$GL_LIBS $GDKGLEXT_WIN_LIBS"
|
||||
GDKGLEXT_DEP_CFLAGS="$GDKGLEXT_EXTRA_CFLAGS `$PKG_CONFIG --cflags $GDKGLEXT_PACKAGES`"
|
||||
diff -r -U 3 a/gdk/x11/Makefile.in b/gdk/x11/Makefile.in
|
||||
--- a/gdk/x11/Makefile.in 2006-02-05 04:17:42.000000000 +0100
|
||||
+++ b/gdk/x11/Makefile.in 2013-12-26 13:12:04.000000000 +0100
|
||||
@@ -257,7 +257,6 @@
|
||||
gdkgldrawable-x11.c \
|
||||
gdkglpixmap-x11.c \
|
||||
gdkglwindow-x11.c \
|
||||
- gdkglfont-x11.c \
|
||||
gdkglglxext.c
|
||||
|
||||
|
||||
@@ -288,7 +287,7 @@
|
||||
am__objects_1 =
|
||||
am__objects_2 = gdkglquery-x11.lo gdkglconfig-x11.lo gdkgloverlay-x11.lo \
|
||||
gdkglcontext-x11.lo gdkgldrawable-x11.lo gdkglpixmap-x11.lo \
|
||||
- gdkglwindow-x11.lo gdkglfont-x11.lo gdkglglxext.lo
|
||||
+ gdkglwindow-x11.lo gdkglglxext.lo
|
||||
am__objects_3 = $(am__objects_1) $(am__objects_2)
|
||||
am_libgdkglext_x11_la_OBJECTS = $(am__objects_3)
|
||||
libgdkglext_x11_la_OBJECTS = $(am_libgdkglext_x11_la_OBJECTS)
|
||||
@@ -299,7 +298,6 @@
|
||||
@AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/gdkglconfig-x11.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/gdkglcontext-x11.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/gdkgldrawable-x11.Plo \
|
||||
-@AMDEP_TRUE@ ./$(DEPDIR)/gdkglfont-x11.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/gdkglglxext.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/gdkgloverlay-x11.Plo \
|
||||
@AMDEP_TRUE@ ./$(DEPDIR)/gdkglpixmap-x11.Plo \
|
||||
@@ -349,7 +347,6 @@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gdkglconfig-x11.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gdkglcontext-x11.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gdkgldrawable-x11.Plo@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gdkglfont-x11.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gdkglglxext.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gdkgloverlay-x11.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gdkglpixmap-x11.Plo@am__quote@
|
Reference in New Issue