genimage: Add patch needed for the test on ARM architectures.
* gnu/packages/patches/genimage-signedness.patch: New file. * gnu/packages/genimage.scm (genimage)[source]: Add patch. * gnu/local.mk (dist_patch_DATA): Register patch.master
parent
44de399151
commit
ee7a7c9014
|
@ -1017,6 +1017,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gd-brect-bounds.patch \
|
||||
%D%/packages/patches/gdb-hurd.patch \
|
||||
%D%/packages/patches/gdm-default-session.patch \
|
||||
%D%/packages/patches/genimage-signedness.patch \
|
||||
%D%/packages/patches/geoclue-config.patch \
|
||||
%D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
|
||||
%D%/packages/patches/ghc-testsuite-dlopen-pie.patch \
|
||||
|
|
|
@ -50,7 +50,9 @@
|
|||
(file-name (string-append name "-" version "-checkout"))
|
||||
(sha256
|
||||
(base32
|
||||
"15jmh17lvm3jw9c92bjarly7iwhmnfl322d91mprfv10ppb9ip54"))))
|
||||
"15jmh17lvm3jw9c92bjarly7iwhmnfl322d91mprfv10ppb9ip54"))
|
||||
;; will be shipped with release 14
|
||||
(patches (search-patches "genimage-signedness.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
commit 6574665f9d6c0757e8f55ccb465afbcaa90bf019
|
||||
Author: Timotej Lazar <timotej.lazar@araneo.si>
|
||||
Date: Wed Aug 19 19:36:02 2020 +0200
|
||||
|
||||
test: normalize flags reported by dumpe2fs
|
||||
|
||||
Filesystem flags depend on the system – usually signed_directory_hash,
|
||||
but unsigned_directory_hash at least on arm64.
|
||||
|
||||
Signed-off-by: Timotej Lazar <timotej.lazar@araneo.si>
|
||||
|
||||
diff --git a/test/basic-images.test b/test/basic-images.test
|
||||
index f6685e1..cb104c3 100755
|
||||
--- a/test/basic-images.test
|
||||
+++ b/test/basic-images.test
|
||||
@@ -158,6 +158,8 @@ check_ext() {
|
||||
# format change
|
||||
csum2="Group 0: (Blocks 1-4095) \\[ITABLE_ZEROED\\]\| Checksum .*, unused inodes 205"
|
||||
dumpe2fs "${1}" | grep -v "^\($uuid\|$seed\|$csum1\|$csum2\)" > "dump" &&
|
||||
+ # some architectures (including arm64) use unsigned char
|
||||
+ sed -i 's/un\(signed_directory_hash\)/\1/' "dump" &&
|
||||
# fixup for ext3 journal size with old tune2fs
|
||||
sed -i 's/^\(Journal size: \)1029k$/\11024k/' "dump" &&
|
||||
# output format changed with some version
|
Reference in New Issue