gnu: python-sip: Update to 6.7.7.
* gnu/packages/patches/python-sip-include-dirs.patch: New file. * gnu/local.mk: Add it. * gnu/packages/qt.scm (python-sip): Update to 6.7.7. [propagated-inputs]: Add python-ply. [source]: Use patch.master
parent
c10bfa8885
commit
eebb0bfd68
|
@ -1648,6 +1648,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/python-random2-getrandbits-test.patch \
|
%D%/packages/patches/python-random2-getrandbits-test.patch \
|
||||||
%D%/packages/patches/python-poppler-qt5-fix-build.patch \
|
%D%/packages/patches/python-poppler-qt5-fix-build.patch \
|
||||||
%D%/packages/patches/python-pypdf-annotate-tests-appropriately.patch \
|
%D%/packages/patches/python-pypdf-annotate-tests-appropriately.patch \
|
||||||
|
%D%/packages/patches/python-sip-include-dirs.patch \
|
||||||
%D%/packages/patches/python-sgmllib3k-assertions.patch \
|
%D%/packages/patches/python-sgmllib3k-assertions.patch \
|
||||||
%D%/packages/patches/python-telingo-fix-comparison.patch \
|
%D%/packages/patches/python-telingo-fix-comparison.patch \
|
||||||
%D%/packages/patches/python-typeguard-python3.10.patch \
|
%D%/packages/patches/python-typeguard-python3.10.patch \
|
||||||
|
|
|
@ -0,0 +1,20 @@
|
||||||
|
Add an environment variable to python-sip that extends its search
|
||||||
|
directories for .sip files.
|
||||||
|
|
||||||
|
It seems that we cannot easily change the destination folder of these
|
||||||
|
files though, so this variable must be set on a per-package basis (and
|
||||||
|
non through search-path).
|
||||||
|
|
||||||
|
--- sip/sipbuild/builder.py 2023-03-22 09:06:37.588792878 +0100
|
||||||
|
+++ sip/sipbuild/builder.py 2023-03-22 09:10:35.830181134 +0100
|
||||||
|
@@ -254,6 +254,10 @@
|
||||||
|
os.path.join(project.target_dir,
|
||||||
|
project.get_bindings_dir()))
|
||||||
|
|
||||||
|
+ # Add extra bindings from environment for GNU Guix.
|
||||||
|
+ if 'SIP_INCLUDE_DIRS' in os.environ:
|
||||||
|
+ sip_include_dirs.extend(os.environ['SIP_INCLUDE_DIRS'].split(os.pathsep))
|
||||||
|
+
|
||||||
|
# Generate the sip.h file for the shared sip module.
|
||||||
|
copy_sip_h(abi_major_version, project.build_dir,
|
||||||
|
project.sip_module, version_info=project.version_info)
|
|
@ -3196,7 +3196,7 @@ instances.")
|
||||||
(define-public python-sip
|
(define-public python-sip
|
||||||
(package
|
(package
|
||||||
(name "python-sip")
|
(name "python-sip")
|
||||||
(version "5.5.0")
|
(version "6.7.7")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -3206,12 +3206,13 @@ instances.")
|
||||||
"/sip-" version ".tar.gz")))
|
"/sip-" version ".tar.gz")))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1idaivamp1jvbbai9yzv471c62xbqxhaawccvskaizihkd0lq0jx"))))
|
"1qm9q9lhfky5zvxxkssf4zdfv5k1zikji4hz80d48vdfm1pw1sfy"))
|
||||||
|
(patches (search-patches "python-sip-include-dirs.patch"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list python-wrapper))
|
(list python-wrapper))
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
(list python-toml python-packaging))
|
(list python-toml python-packaging python-ply))
|
||||||
(home-page "https://www.riverbankcomputing.com/software/sip/intro")
|
(home-page "https://www.riverbankcomputing.com/software/sip/intro")
|
||||||
(synopsis "Python binding creator for C and C++ libraries")
|
(synopsis "Python binding creator for C and C++ libraries")
|
||||||
(description
|
(description
|
||||||
|
|
Reference in New Issue