me
/
guix
Archived
1
0
Fork 0

gnu: openrgb: Update to 0.9.

* gnu/packages/hardware.scm (openrgb): Update to 0.9.
* gnu/packages/patches/openrgb-unbundle-hueplusplus.patch: Update.
master
John Kehayias 2023-07-10 11:21:31 -04:00
parent b7be0a999d
commit ef0a45c641
No known key found for this signature in database
GPG Key ID: 499097AE5EA815D9
2 changed files with 7 additions and 7 deletions

View File

@ -1017,7 +1017,7 @@ technology, such as head mounted displays with built in head tracking.")
(define-public openrgb (define-public openrgb
(package (package
(name "openrgb") (name "openrgb")
(version "0.8") (version "0.9")
(source (source
(origin (origin
(method git-fetch) (method git-fetch)
@ -1026,7 +1026,7 @@ technology, such as head mounted displays with built in head tracking.")
(commit (string-append "release_" version)))) (commit (string-append "release_" version))))
(file-name (git-file-name name version)) (file-name (git-file-name name version))
(sha256 (sha256
(base32 "1yz7sdrjcxajm1zpa5djinmych5dvck0r1fvk0x5qmk87va4p9z3")) (base32 "0rdh87w4j47dr0vakva94fhcbdc67d9aad0p3najg9zf8zhf64jw"))
(patches (patches
(search-patches "openrgb-unbundle-hueplusplus.patch")) (search-patches "openrgb-unbundle-hueplusplus.patch"))
(modules '((guix build utils))) (modules '((guix build utils)))

View File

@ -1,10 +1,10 @@
Remove references to hueplusplus in order to unbundle and use the input package. Remove references to hueplusplus in order to unbundle and use the input package.
diff --git a/OpenRGB.pro b/OpenRGB.pro diff --git a/OpenRGB.pro b/OpenRGB.pro
index 61758892..8702d998 100644 index 556be3bc..41e704aa 100644
--- a/OpenRGB.pro --- a/OpenRGB.pro
+++ b/OpenRGB.pro +++ b/OpenRGB.pro
@@ -493,35 +493,6 @@ SOURCES += @@ -783,35 +783,6 @@ SOURCES +=
dependencies/Swatches/swatches.cpp \ dependencies/Swatches/swatches.cpp \
dependencies/dmiinfo.cpp \ dependencies/dmiinfo.cpp \
dependencies/ColorWheel/ColorWheel.cpp \ dependencies/ColorWheel/ColorWheel.cpp \
@ -40,15 +40,15 @@ index 61758892..8702d998 100644
dependencies/libe131/src/e131.c \ dependencies/libe131/src/e131.c \
dependencies/libcmmk/src/libcmmk.c \ dependencies/libcmmk/src/libcmmk.c \
main.cpp \ main.cpp \
@@ -1188,6 +1159,7 @@ unix:!macx { @@ -1789,6 +1760,7 @@ contains(QMAKE_PLATFORM, linux) {
-lmbedx509 \
-lmbedtls \ -lmbedtls \
-lmbedcrypto \ -lmbedcrypto \
-ldl \
+ -lhueplusplusshared \ + -lhueplusplusshared \
COMPILER_VERSION = $$system($$QMAKE_CXX " -dumpversion") COMPILER_VERSION = $$system($$QMAKE_CXX " -dumpversion")
if (!versionAtLeast(COMPILER_VERSION, "9")) { if (!versionAtLeast(COMPILER_VERSION, "9")) {
@@ -1218,7 +1190,6 @@ unix:!macx { @@ -1821,7 +1793,6 @@ contains(QMAKE_PLATFORM, linux) {
} }
SOURCES += \ SOURCES += \