me
/
guix
Archived
1
0
Fork 0

gnu: pitivi: Fix build with Meson 0.60.

* gnu/packages/patches/pitivi-fix-build-with-meson-0.60.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/video.scm (pitivi)[source]: Use it.
master
Leo Famulari 2021-11-25 19:02:36 -05:00
parent 6034c3599b
commit ef717037c8
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 48 additions and 0 deletions

View File

@ -1554,6 +1554,7 @@ dist_patch_DATA = \
%D%/packages/patches/pango-skip-libthai-test.patch \
%D%/packages/patches/pciutils-hurd-configure.patch \
%D%/packages/patches/pciutils-hurd-fix.patch \
%D%/packages/patches/pitivi-fix-build-with-meson-0.60.patch \
%D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
%D%/packages/patches/pthreadpool-system-libraries.patch \

View File

@ -0,0 +1,46 @@
From b54da52289f9578d7021f466d731cfd48330e5fe Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Thu, 25 Nov 2021 18:56:44 -0500
Subject: [PATCH] Fix build with Meson 0.60.
https://gitlab.gnome.org/GNOME/pitivi/-/issues/2593
* data/meson.build: Adjust to changes in Meson 0.60.
---
data/meson.build | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/data/meson.build b/data/meson.build
index 2ea82cf..60d2316 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -6,7 +6,7 @@ install_subdir('audiopresets', install_dir: pkgdatadir)
install_subdir('videopresets', install_dir: pkgdatadir)
install_subdir('gstpresets', install_dir: pkgdatadir)
-desktop_file = i18n.merge_file('org.pitivi.Pitivi.desktop',
+desktop_file = i18n.merge_file(
type: 'desktop',
output : 'org.pitivi.Pitivi.desktop',
input : 'org.pitivi.Pitivi.desktop.in',
@@ -25,7 +25,7 @@ if desktop_file_validate.found()
)
endif
-appdata_file = i18n.merge_file('org.pitivi.Pitivi.appdata.xml',
+appdata_file = i18n.merge_file(
type: 'xml',
output : 'org.pitivi.Pitivi.appdata.xml',
input : 'org.pitivi.Pitivi.appdata.xml.in',
@@ -43,7 +43,7 @@ if appstream_util.found()
)
endif
-i18n.merge_file('org.pitivi.Pitivi-mime.xml',
+i18n.merge_file(
output : 'org.pitivi.Pitivi-mime.xml',
input : 'org.pitivi.Pitivi-mime.xml.in',
po_dir: podir,
--
2.33.1

View File

@ -4375,6 +4375,7 @@ tools for styling them, including a built-in real-time video preview.")
(url "https://gitlab.gnome.org/GNOME/pitivi.git")
(commit %version)))
(file-name (git-file-name name version))
(patches (search-patches "pitivi-fix-build-with-meson-0.60.patch"))
(sha256
(base32 "08x2fs2bak1fbmkvjijgx1dsawispv91bpv5j5gkqbv5dfgf7wah"))))
(build-system meson-build-system)