From efc3ff4788e4f8a2776104213a56ec10e41029bf Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:44:18 +0200
Subject: [PATCH] gnu: Add texlive-beamerappendixnote.

* gnu/packages/tex.scm (texlive-beamerappendixnote): New variable.
---
 gnu/packages/tex.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 75d2d5be2c..924c241c74 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -73618,6 +73618,28 @@ presentation from right to left.  It requires Babel with the LuaTeX engine.")
      "The package specifies a Beamer theme for presenting a thesis.")
     (license license:lppl)))
 
+(define-public texlive-beamerappendixnote
+  (package
+    (name "texlive-beamerappendixnote")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/beamerappendixnote/"
+                   "source/latex/beamerappendixnote/"
+                   "tex/latex/beamerappendixnote/")
+             (base32
+              "1cn3hygzahvprhhl9vn95iqkaywp19q61caa6rvyq2krq5m7r5wy")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/beamerappendixnote")
+    (synopsis "Create notes on appendix frames in beamer")
+    (description
+     "This package introduces the @code{\\appxnote} command, which puts the note's
+content on a separate Beamer frame shown by the command
+@code{\\printappxnotes}.  It also creates interactive buttons to move back and
+forth between the two frames.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar