me
/
guix
Archived
1
0
Fork 0

gnu: sbcl: Fix riscv build.

* gnu/packages/patches/sbcl-fix-riscv-build.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/lisp.scm (sbcl)[source]: Use it.

Change-Id: I63f1b9a7a7b6f3a1961d0a0cb31189b74a60abc3
master
Guillaume Le Vaillant 2024-01-10 22:57:43 +01:00
parent 749c3e016a
commit f122f2bead
No known key found for this signature in database
GPG Key ID: 6BE8208ADF21FE3F
3 changed files with 25 additions and 3 deletions

View File

@ -20,7 +20,7 @@
# Copyright © 2018, 2019, 2020, 2021, 2022 Oleg Pykhalov <go.wigust@gmail.com>
# Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
# Copyright © 2018, 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
# Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
# Copyright © 2019, 2020, 2021, 2022, 2044 Guillaume Le Vaillant <glv@posteo.net>
# Copyright © 2019, 2020 John Soo <jsoo1@asu.edu>
# Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
# Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
@ -2004,6 +2004,7 @@ dist_patch_DATA = \
%D%/packages/patches/sbcl-clml-fix-types.patch \
%D%/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch \
%D%/packages/patches/sbcl-fix-ppc64-build.patch \
%D%/packages/patches/sbcl-fix-riscv-build.patch \
%D%/packages/patches/sbcl-png-fix-sbcl-compatibility.patch \
%D%/packages/patches/scalapack-gcc-10-compilation.patch \
%D%/packages/patches/scheme48-tests.patch \

View File

@ -14,7 +14,7 @@
;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019, 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2019 Jesse Gildersleve <jessejohngildersleve@protonmail.com>
;;; Copyright © 2019-2023 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019-2024 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
@ -447,7 +447,9 @@ an interpreter, a compiler, a debugger, and much more.")
version "-source.tar.bz2"))
(sha256
(base32 "0xhpdnsg8idzxkn20iw8gd2rk470d7vc22vrp5clq9fj117vgn43"))
(patches (search-patches "sbcl-fix-ppc64-build.patch"))
;; TODO: Remove these patches when updating to sbcl > 2.4.0.
(patches (search-patches "sbcl-fix-ppc64-build.patch"
"sbcl-fix-riscv-build.patch"))
(modules '((guix build utils)))
(snippet
'(begin

View File

@ -0,0 +1,19 @@
commit b286d92af7468164c155c70d38213211b296fdfe
Author: Douglas Katzman <dougk@google.com>
Date: Wed Jan 10 11:46:55 2024 -0500
Fix riscv build
diff --git a/src/compiler/riscv/float.lisp b/src/compiler/riscv/float.lisp
index ce46d24ac..a16380293 100644
--- a/src/compiler/riscv/float.lisp
+++ b/src/compiler/riscv/float.lisp
@@ -578,7 +578,7 @@
(:results (res :scs (double-reg)))
(:arg-types signed-num)
(:result-types double-float)
- (:translate make-double-float)
+ (:translate %make-double-float)
(:policy :fast-safe)
(:generator 2
(inst fmvx-> :double res bits)))