gnu: dunst: Update to 1.8.1.
* gnu/packages/dunst.scm (dunst): Update to 1.8.1. * gnu/packages/patches/dunst-1.7.3-fix-crash.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
parent
4ba792fa15
commit
f1aa1f3412
|
@ -1008,7 +1008,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/dovecot-trees-support-dovecot-2.3.patch \
|
||||
%D%/packages/patches/dstat-fix-crash-when-specifying-delay.patch \
|
||||
%D%/packages/patches/dstat-skip-devices-without-io.patch \
|
||||
%D%/packages/patches/dunst-1.7.3-fix-crash.patch \
|
||||
%D%/packages/patches/dvd+rw-tools-add-include.patch \
|
||||
%D%/packages/patches/dynaconf-unvendor-deps.patch \
|
||||
%D%/packages/patches/ecl-16-format-directive-limit.patch \
|
||||
|
|
|
@ -5,6 +5,7 @@
|
|||
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
|
||||
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
|
||||
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
|
||||
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -40,7 +41,7 @@
|
|||
(define-public dunst
|
||||
(package
|
||||
(name "dunst")
|
||||
(version "1.7.3")
|
||||
(version "1.8.1")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -49,8 +50,7 @@
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1ra0ii805w3rrs0qqbjxzl6i79ksz42lnvbglw18h4igkza21kzj"))
|
||||
(patches (search-patches "dunst-1.7.3-fix-crash.patch"))))
|
||||
"19bh5789whlc0n5wbyx3yx8px93hccn42f1p6i1dz96hdkk5mjb8"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:tests? #f ; no check target
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
Author: Danny Milosavljevic <dannym@scratchpost.org>
|
||||
Date: 2022-02-04 21:52:05 CET
|
||||
|
||||
Fix crash if notification contains invalid pixbuf data.
|
||||
|
||||
diff -ru /gnu/store/5885czxhmhkckjqj939b0hd6b6czizwb-dunst-1.7.3-checkout/src/notification.c 5885czxhmhkckjqj939b0hd6b6czizwb-dunst-1.7.3-checkout/src/notification.c
|
||||
--- /gnu/store/5885czxhmhkckjqj939b0hd6b6czizwb-dunst-1.7.3-checkout/src/notification.c 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ 5885czxhmhkckjqj939b0hd6b6czizwb-dunst-1.7.3-checkout/src/notification.c 2022-02-04 19:05:57.534906600 +0100
|
||||
@@ -359,8 +359,10 @@
|
||||
g_clear_pointer(&n->icon_id, g_free);
|
||||
|
||||
GdkPixbuf *icon = icon_get_for_data(new_icon, &n->icon_id, draw_get_scale());
|
||||
- n->icon = gdk_pixbuf_to_cairo_surface(icon);
|
||||
- g_object_unref(icon);
|
||||
+ if (icon) {
|
||||
+ n->icon = gdk_pixbuf_to_cairo_surface(icon);
|
||||
+ g_object_unref(icon);
|
||||
+ }
|
||||
}
|
||||
|
||||
/* see notification.h */
|
Reference in New Issue