From f2a3ff859119a81c6d302c552d404bf0462b09e3 Mon Sep 17 00:00:00 2001
From: Kyle Meyer <kyle@kyleam.com>
Date: Sat, 14 Sep 2019 02:15:33 -0400
Subject: [PATCH] gnu: git-annex: Build with MagicMime support.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

git-annex has a mechanism for configuring whether a file is added to the annex
or stored in git.  Building with MagicMime support makes it possible to
condition the behavior on a file's MIME type.

* gnu/packages/haskell-apps.scm (git-annex)[inputs]: Add ghc-magic.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/haskell-apps.scm | 1 +
 1 file changed, 1 insertion(+)

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 8c4048aa66..1341994e60 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -337,6 +337,7 @@ unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
        ("ghc-http-conduit" ,ghc-http-conduit)
        ("ghc-http-types" ,ghc-http-types)
        ("ghc-ifelse" ,ghc-ifelse)
+       ("ghc-magic" ,ghc-magic)
        ("ghc-memory" ,ghc-memory)
        ("ghc-monad-control" ,ghc-monad-control)
        ("ghc-monad-logger" ,ghc-monad-logger)