From f2b8f7f7e1da06f8a1b58bf763d4b6c23abf1f40 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Thu, 13 Jul 2023 10:56:51 +0200
Subject: [PATCH] gnu: Add texlive-tzplot.

* gnu/packages/tex.scm (texlive-tzplot): New variable.
---
 gnu/packages/tex.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cd302d60c1..31e510dc40 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5620,6 +5620,27 @@ open source emojis through LaTeX commands.  This relies on images, so no fancy
 Unicode font stuff is needed and it should work on every installation.")
     (license (list license:lppl1.3+ license:cc-by4.0))))
 
+(define-public texlive-tzplot
+  (package
+    (name "texlive-tzplot")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/tzplot/" "tex/latex/tzplot/")
+             (base32
+              "09k84vjvl3qkp8jffv3j5bksq3jaad2p71yj715z39qf36hwvm7s")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tzplot")
+    (synopsis "Plot graphs with TikZ abbreviations")
+    (description
+     "This is a LaTeX package that provides TikZ-based macros to make it easy
+to draw graphs.  The macros provided in this package are just abbreviations
+for TikZ codes, which can be complicated; but using the package will hopefully
+make drawing easier, especially when drawing repeatedly.  The macros were
+chosen and developed with an emphasis on drawing graphs in economics.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-amiri
   (package
     (name "texlive-amiri")